I am getting this error when trying to sign in to MS Teams and I'm not sure what it means.

enter image description here

Does anyone know what is causing it?

4 Answers 4


This happened to me today. After my corporate IT team made some changes to my account, I found that when I tried to switch from MyCompany's Teams org to aClient's Teams org (same email/account, I'm a "guest" in the second org) I got the 'login_hint' message above.

I tried the above solution about deleting the contents of %appdata%\Microsoft\Teams but it didn't help.

The solution I found was (simply, and slightly depressingly) to Sign Out of Teams and sign back in again. This seemed to trigger something that fixed the problem.

Hope this helps someone...

  • 1
    .... I hate the fact this worked for me. Oct 23, 2019 at 21:55
  • Sign out is not that obvious so it might have worked, however this approach doesnt work at Linux even with erasing all files from /usr/share/teams.
    – FantomX1
    Nov 18, 2020 at 20:39

This worked for me. Enabled the "Advanced diagnostics" and quit the Teams. Weird but worked!

Hope it helps you too.


What helped for me was erasing cache as written in Microsoft forums.


Marvin Ma MSFTReplied on April 29, 2019 Microsoft Agent | Moderator Hi Chabbi,

I've checked the incident TM173756 and it was resolved in February 18, 2019. So your issue could be caused by different factors. Based on the error, you cannot sign in Teams. In this scenario, please follow the steps below to check if it helps.

  1. Fully exit the Microsoft Teams desktop client. To do this, either right click Teams from the Icon Tray and select ‘Quit’, or run Task Manager and fully kill the process.

  2. Go to File Explorer, and type in "%appdata%\Microsoft\teams".

  3. Once in the directory, delete all the files and re-open Teams.

Meanwhile, please check if you can sign in Teams on the web. It will help us determine whether it's a client issue. For the further investigation, please capture a screenshot of the entire error message and upload in the post.


On Ubuntu / Linux I had the same issue , with hint and redirecting. Nothing helped , no single browser , no desktop app, not erasing all the existing settings at the /usr/share/teams, /home/*user*/.config/teams /root/.config/Microsoft/Microsoft Teams directories, what helped was setting up my Os time to automatic, as it was way off.

Maybe connected to Microsoft Teams not working in Arch/Manjaro - systemwide issue

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .