0

I am somewhat confused as what can be the cause of it. I disabled everythin in vim (replaced .vimrc with a blank file) and still, when I press Esc+left, I delete the 3 lines above my cursor, and with Esc+left, I delete the 3 lines below AND I end up in Insert mode.

I have started vim in verbose mode to see more info, but all I am getting is:

Executing CursorMoved Autocommands for "*"
autocommand call s:Highlight_Matching_Pair()
Press ENTER or type command to continue
Executing CursorMoved Autocommands for "*"
Press ENTER or type command to continue
autocommand call s:OnCursorMovedNormalMode()
Press ENTER or type command to continue
Executing TextChanged Autocommands for "*"
Press ENTER or type command to continue
autocommand call s:Highlight_Matching_Pair()
Press ENTER or type command to continue
Executing TextChanged Autocommands for "*"
Press ENTER or type command to continue
autocommand call s:OnTextChangedNormalMode()
Press ENTER or type command to continue

Is there anyway to debug this and see where this behaviour comes from? I also deleted my .vim/ folder to make sure no plugin was interfering.

Thanks~!

0

I just noticed this is produced by my Terminal Emulator, Terminator. More info coming.

UPDATE: I had the following configuring line in my .tmux.conf:

set-window-option -g xterm-keys on

This made the terminal print the keys every time I press ESC+. This of course, made vim delete lines.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.