0

I've installed KDE Plasma on Fedora 30 Workstation. The resolution was at the lowest but attempting to change the value in System Settings does not work. The monitor supports the resolution. Upon pressing the apply button it sets the resolution but then reverts in a second. The resolutions work on GNOME and Deepin Desktop but not on KDE. Even setting the resolution with xrandr -s 1920x1080 it will revert back after a second.

New contributor
JoshBaz is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • Did you install Fedora or a Fedora spin with KDE already integrated, or tried adding KDE yourself as an additional DE? KDE has endless pieces, and the meta package in the repository typically doesn't contain everything. Even with all the pieces, integrating it into the distro isn't trivial. That's the reason Mint dropped KDE; it was eating their resources. There used to be a Fedora spin called Korora, which incorporated KDE, but that project shut down for the same reason. (cont'd) – fixer1234 Aug 13 at 21:45
  • Your best bet to get up and running with KDE on Fedora without brain damage is to install a spin that has it already integrated. Check out spins.fedoraproject.org/kde – fixer1234 Aug 13 at 21:46
  • @fixer1234 I installed it from the default ISO provided, not a spin. Installed the KDE using dnf in terminal. Is there a difference? I'll try getting a spin – JoshBaz Aug 14 at 16:24
  • There's a difference. KDE isn't like a software package, where you just specify the package name and tell the package manager to install it. It's an endless collection of packages, many of which are not part of the meta package. Even if you know every package, integration isn't simple. There are different choices of supporting packages, and the chance for dependency conflicts. What you see as the KDE version of a distro required a lot of work by the maintainers to integrate and customize it. – fixer1234 Aug 14 at 17:21
0

I found the solution. Its a module called KScreen that causes the automatic resolution change. It needs to be disabled in the service manager.

Steps to stop KScreen module

New contributor
JoshBaz is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

JoshBaz is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.