0

I have setup a nodejs highcharts-export-server on Centos7 and ubuntu server 18.04 with command

sudo npm install -g highcharts-export-server

After this i do

sudo npm install -g forever

and, in /usr/lib/node-modules/highcharts-export-server/bin,

forever start --killSignal SIGINT ./cli.js --enableServer 1

The otuput of forever is good, the export-server starts and it waits for requests on port 7801.

Now: if i call with curl command

curl --noproxy "*" -H "Content-Type: application/json" -X POST -d '{"infile":{"title": {"text": "Steep Chart"}, "xAxis": {"categories": ["Jan", "Feb", "Mar"]}, "series": [{"data": [29.9, 71.5, 106.4]}]},"type":"svg"}' 127.0.0.1:7801 -o mychart.svg

request to export-server goes in timeout with no response.

If i change the last parameter at the end of my call string from "type":"svg" to "type":"png" and i adjust the name of the output file from mychart.svg to mychart.png all goes well.

This happens in both systems (Centos and Ubuntu).

Obviously i need a svg image and not a png.

Where am i wrong?

Thanks a lot.

New contributor
Enrico Sambo is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

Enrico Sambo is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.