0

I am running into an inconsistency while using ulimit. I make changes directly to the conf file "/etc/security/limits.conf".

Whenever I use just user names, I have zero problems. For example:

root hard as 16777207
user1 hard as 4194304
user2 hard as 4194304

The second I try to use * wildcard or @groups, things start to get wierd. For example:

* hard as 4194304 
@group hard as 4194304
root hard as 16777207

all users including root have "as" value of 4194304. my group list is huge, 100's of users who change, so managing this .conf file with users is not an option.

How can i solve the issue where using the wildcard or @group also changes root value, when i want root to have its very own values?

Thanks!!!!

New contributor
user3808748 is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • superuser.com/q/1200539/365297 may be related. Another thing that comes to mind is that perhaps the order is relevant, so put the root line first (although I find no evidence that order does matter). – wurtel Aug 14 at 7:00
  • Thanks for linking me to the thread, but that looks like its about an issue on setting soft or hard values. I am able to do that no problem, it is just that root is always getting the setting applied. I have tried different orders as well as using the limit.d folder to load it separately. Perhaps it is another bug. I was able to reproduce it in multiple systems. – user3808748 Aug 14 at 16:41
0

ok i got this to work by putting

root @group root

for some reason i need to specify root value before and after, if i dont by only having it on top or bottom it would not work! STRANGE!

New contributor
user3808748 is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

user3808748 is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.