0

I am not a tech-savvy person , but i am also not a tech-blind-person , just your average noob user .

I have this Crucial M4 SSD 128GB i got myself from workplace storage . The admins said i can have it since it is broken and sitting there eating dust . I used MX Linux 18.3 , when i tried to connect it via USB it won't mount , i then run the Disk Manager , it won't show the disk.

When using GSmartControl i found the disk properly . When i used GParted to rewrite the SSD so i can install a Linux inside it , GParted give me "input/output error during read on /dev/sdc" , there's retry , cancel , and ignore button .

Retry : the same message

Cancel : the same message then enter GParted GUI

Ignore : "the backup GPT table is corrupt , but the primary appears OK , so that will be used" , then enter GParted GUI

GParted then read the SSD as 2TiB Unallocated , but when i tried to create new it returns the same error as when i first start GParted , i tried to create partition table like GParted suggested , but it returns the same error . I then tried to google to find out what's the problem , then i found this . But after 12 hours it stills run but don't show any result just outputting Analyze Cylinder : 10435/267348 : 02% . How to fix this ?

My Goal : To make the SSD reusable so i can install a linux on top of it , i don't care if all the data will be lost .

EDIT : i remember the admin said it was used Mac OS X and something like Bootcamp windows or something like that . FYI , i don't have access to Mac .

  • If you tried to create a new partition table (not the same as a new partition) with Gparted (Device (menu) > New partition table... (GPT)) and got an error then it is broken just like your colleagues told you and you're wasting your time (and electricity). – GabrielaGarcia Aug 14 at 3:01
  • but the gsmart determined that the partition is healthy and properly identified that it is 128GB ssd . is there something i can try before giving up ? – user1075591 Aug 14 at 12:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy