0

OS: Windows 10 Pro Version 1903

WSL: Ubuntu 18.04.3 LTS

Display:

  • 1920 x 1080 - 21.5"

  • Scaling 100% (Recommended)

After reading many posts here, here, here and here and but no help. Basically, I already tried

  • Properties > Compatibility tab > Change high DPI settings > Enable Override high DPI scaling > change to 'Application'

  • export GDK_SCALE=0.5 (and adjusted the value multiple times)

  • export GDK_DPI_SCALE=2 (and adjusted the value multiple times)

  • tried both VcXsrv and MobaXterm

But doing the above and adjusting the values of GDK_SCALE and GDK_DPI_SCALE have no effect at all on the GUI quality. The apps I tried to fix is RStudio which actually is a browser. It's really weird.

The above don't work at all so I play around around with MobaXterm's DPI settings. Settings > X11 (tab) > DPI.

Adjusting the DPI values do alter a few elements such as the menu bar (it will increase/decrease the font size) but it has no effect on the main body

enter image description here

Please help. Thank you.

  • 1
    WSL is not meant for GUI things. Use a real GNU/Linux distrbuiton. – Biswapriyo Aug 14 at 9:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.