I am attempting to run Firefox in headless mode. I have made a new profile called 'headless'. Here is what I get when running the command from a terminal in Fedora 30: (I can wait several minutes before cancelling the process but nothing happens)

>>$ firefox -headless http://www.google.com -P headless
*** You are running in headless mode.
^CExiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.

Not sure what's going wrong as I expected it to be as simple as adding the headless option and that's that. I haven't been able to find anybody else with a similar issue.

I'm looking for a more minimal browser for web development in my setup with i3wm. I'm not even sure if headless mode is exactly what I want (i.e. just a panel to display my webpage with no extra UI elements), but it sounds like it is. I've been able to produce a similar result with chrome in kiosk mode (although having to open it and then exit out of fullscreen mode to achieve the effect is unideal), but I would prefer to be able to use firefox.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.