2

Model: New Dell XPS 15 7590

OS Version: Ubuntu 19.04

Kernel Version: 5.0.25/5.1.21 (I've tried all below on both versions, neither resolves the issue)

The Problem:

Ubuntu does not detect a Wi-Fi card attached to the computer, seemingly because of driver issues. lspci says that the Network Controller is an Intel Corporation Device 2723 (rev 1a), and lshw -c network confirms that it is an Intel Corporation device that is marked UNCLAIMED, implying a driver issue of some kind. rfkill shows a working Bluetooth device, but doesn't list anything for Wi-Fi.

Interestingly, the Dell website says the card is a Killer Wi-Fi 6 AX1650 (2x2), and it functions well on the Windows install in this machine (after installing appropriate Killer drivers).

Attempted Fixes:

I've scoured the internet for hours. What I've tried:

  1. Upgrading to Kernel version 5.1 (Problem Persisted)
  2. Upgrading to 5.2 (Persisted, later uninstalled 5.2)
  3. Forcing reinstall of linux-modules-extra-$(uname -r), which errored out on all kernel versions. On 5.0, it fails to install broadcom-sta-dkms, as the module, for some reason, tries to initialize installation for kernel version 5.2.8, despite uninstallation of 5.2. On 5.1 and 5.2, apt can't find the package.
  4. Purging bcmw-kernel-source and installing ubuntu-restricted-extras. Fails for the same broadcom-sta-dkms issues as above.
  5. Everything else I've come across so far. Nothing has worked, and I am officially lost.

Any ideas? Is this Wi-Fi card just incompatible with current Linux?

New contributor
M. Apinis is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • 1
    I'd test temporarily with Ubuntu 18.04 LTS (yes, going backwards) on a USB drive (no need to install) to see if the issue is the newer OS. The LTS versions are pretty good about including drivers. Another option is a WiFi dongle, but that should not be needed! – DrMoishe Pippik Aug 14 at 17:54
  • 1
    What is the vendor:product ID from lspci -nn (or lspci -tvnn)? – grawity Aug 14 at 17:59
  • @DrMoishe I initially did install 18.04, I forgot that in my original post, and it didn't work. I went up to 19.04 in hopes that the newer version would have the drivers for a new computer, but no dice. – M. Apinis 2 days ago
  • @grawity lspci -nn | grep Network returns 3b:00.0 Network controller [0280]: Intel Corporation Device [8086:2723] (rev 1a) – M. Apinis 2 days ago
1

Have tried this one: https://support.killernetworking.com/knowledge-base/killer-ax1650-in-debian-ubuntu-16-04/

Just got my new XPS 15 and still figuring things out. You're further along with OS installed, give it a shot maybe

New contributor
Art Rosnovsky is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • 1
    Thank you! Of all the things I read online, looks like I missed this. Quick caution though: the article notes a patch that needs to be made, but the article is outdated and the patch has been pushed to master, no need to try to apply it yourself. – M. Apinis 2 days ago
  • Awesome!! Thanks for confirming, I'm done with the installation and off to fix the wifi! :)) – Art Rosnovsky 2 days ago

Your Answer

M. Apinis is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.