2

After a recent Windows update, the default option (when I press Alt-F4) in the Shut Down Windows dialog in Windows 10 has changed on my laptop:

Shut Down Dialog in Windows 10

The default option is now Switch user. Previously it was what I wanted: Shut down.

How can I restore Shut down as the default?1

Windows version: Windows 10 Home2

1. To avoid a catastrophic mistake, I would prefer not to edit the registry.

2. When I entered the question, the build was v1803. While processing the accepted answer, I rebooted Windows and it updated to v1903.

  • You will have to edit the registry or use software on this page....winaero.com/blog/set-default-action-shutdown-dialog-windows-10 – Moab 2 days ago
  • 1
    Since you are using Windows 10 Home, using the registry editor, is your only solution. I have provided a reference link, if you truely want to avoid the registry editor, use the .reg files provided in the reference article. However, it truely is as simple, as changing the value of the key. – Ramhound 2 days ago
1

The displayed default action is set in :
Power Options > Choose what the power buttons do > When I press the power button.

Set the options of "On battery" and "Plugged in" both to "Shut down". This should also change the default action.


An alternative solution for Windows versions Pro and above (not Home) is to :

  • Start the Local Group Policy Editor (gpedit.msc)
  • Expand User Configuration > Administrative Templates > Start Menu and Taskbar
  • Double-click on Change Start Menu power button policy to edit it
  • Set the policy to "Enabled" and then the action to "Shut Down"
  • Click OK and reboot.

For the poster, this was still not enough.

So we checked Windows integrity by running sfc /scannow. This, together with a Windows Update and some reboots, finally made this setting stick.

  • Power Options => via Control Panel (icons view). – Wikis 2 days ago
  • Does not work. Options are unchanged. – Wikis 2 days ago
  • I added another option, if your Windows version is not Home. If all the suggested actions, including the registry edit by Ramhound fail, then something is wrong with the computer. – harrymc 2 days ago
  • I have Windows Home, so no Local Group Policy Editor. I think it is too early to conclude that "something is wrong with the computer". – Wikis 2 days ago
  • See How to Access the Group Policy Editor, Even in Windows Home. And, yes, it's too early to conclude anything, but my first advice worked for me, so there is no reason it wouldn't work for you. – harrymc 2 days ago
-1

To avoid a catastrophic mistake, I would prefer not to edit the registry.

Unless you are careless it is not possible to make a catastrophic mistake in this case. Since you are using Windows 10 Home modifying the value in the registry is the only way to make this change since you are unable to use the group policy editor. Any solution described in this answer requires you to be an Administrator on the machine.

After a recent Windows update, the default option in the Shut Down Windows dialog in Windows 10 has changed on my laptop to Switch user previously it was Shut Down

How can I restore Shut down as the default?

Within Registry Editor navigate to HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced and modify the Start_PowerButtonAction value to 0x2 (i.e. 00000002) from 0x100 (i.e. 00000100). This will change the default behavior for the current user profile.

If you want to change the default behavior for all users on the machine modify the PowerButtonAction key to 0x2 (i.e. 00000002) at the following locations:

HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Windows\Explorer

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Explorer

Source: How to Change Default Action of Shut Down Windows Dialog in Windows 10

  • You can either create the DWORD key yourself or use the registry files in the reference article. However, make sure you check, both locations for the applicable key. – Ramhound 2 days ago
  • I made all the changes you recommended and rebooted. Dialog default option is unchanged. – Wikis 2 days ago

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.