2

Last week, a 500 GB solid state drive failed in my main desktop PC. I replaced the failed drive with a new 500 GB solid state drive, re-installed my OS and programs; everything works fine again.

I want to recover my data from the bad solid state drive, and have a cable that allows me to plug my SSD SATA drive into a USB port. When I do this on my desktop PC, the drive appears as drive I:, but access is futile. I tried this on several different PCs; all failed.

So this is all expected behavior, since my drive did go bad. But, with my work laptop, an HP Elitebook 840 G4, when I plug my failed drive into its USB port, the failed drive appears and I can access it! I only have about 5 minutes of access before it dismounts; then I have to unplug it and re-plug it in again.

I was able to copy all my data from the bad drive, however, I can't access my Users folder. The reason is because Windows puts ACL permissions on that folder. Because my laptop is a work laptop, I cannot write to external media, which means I can't reset the ACL permissions to access my Users folder.

So my question is, does anyone know why my drive would work on this one laptop, but not on any other machine I've plugged it into? Both my home computer and my work computer are Windows 10 64-bit edition. I use Windows 10 Professional at home and my work computer is Windows 10 Enterprise, but that shouldn't matter. I've tried about 4 different machines, with no luck.

1
  • @K7AAY - That worked!
    – Icemanind
    Aug 17 '19 at 2:04
0

Can't say why; HP likely uses a different USB controller than your other boxen, and it's able to read through the USB-SATA III interface. However, if you boot your work laptop with a Linux LiveUSB, you may be able to copy the contents of the failed drive's \USER\YOURNAME directory into your NTFS partition on the laptop's local drive, or to another USB drive, bypassing both the ACL and the no external drive writing restriction of your work PC's Enterprise Windows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.