I'm on a PC windows 10 and always open git bash, then source activate my-env and open a jupyter notebook; somehow my-env broke and I get this error:

"C:\bld\conda_1565126647711_h_env/etc/profile.d/conda.sh: No such file or directory"

Also, I cannot activate "my-env" in a jupyter notebook and I'm getting a "kernal error" in jupyter; but I am able to activate the environment from command prompt.

I've tried:

  • typing the entire file path into bash
  • deleting the env in bash
  • deleting the env from command prompt (still can activate it from CMD)
  • opening jupyter from CMD; still get the kernal error there
  • echo ". C:\Users\mngav\Anaconda3\etc\profile.d\conda.sh" >> ~\.bashrc which worked for a colleague but was not successful for me.

Should I just hard reset my comp and set up the environment form scratch?

  • 1
    Before you reinstall Windows, to solve a Anaconda problem, I would simply reinstall Python and Anaconda.
    – Ramhound
    Aug 16, 2019 at 18:40

1 Answer 1


Ok, so I'm by no means good at this, but I think I figured out a work-around.

In the "activate" file located H:\anaconda3\Scripts\activate I first changed the path in _CONDA_ROOTto point to my conda folder H:\anaconda3 in my case. (I have no idea what the bld paths are for but that's what messed things up for me)

Then in the file H:\anaconda3\etc\profile.d\conda.sh I changed export CONDA_EXE to point to my conda.exe location; H:\anaconda3\Scripts\conda.exe

Then in git bash I was able to use source activate myenv and it seems to be working fine again.

This issue happened to me after updating my anaconda navigator. I was hoping that would not mess up my normal workflow of using git bash for most things but I guess it did.

P.S. I was not able to use source activate in the windows command prompt but conda activate works. Not sure if this is related though.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .