In short: about 50% of the time I have a screwed up monitor setup after reboot. About 50% it is totally correct.

Now the longer version:
I updated my machine from 9.04 to 10.04 (via 9.10). At first I run into some monitor problems (I have a 3-monitor setup) because of the known bug in the new xserver driver for xinerama. This messes up behaviour if the mouse goes either left or above the screen number 0, i.e. I had to make my left-most monitor screen 0.
Everything worked out fine finally, I got my 3-monitor setup back with xinerama enabled to get one big desktop streched over 3 screens.

Now the fun part:
Every time I start up my machine only one of the 3 monitors gets a signal and is woken up: it only recognizes the left-most monitor (screen 0) and crams all the desktop stuff into this one screen. If I go into nvidia settings I only see one physical device although all 3 are connected and have power. When I look into the xorg.conf I can still see my old setup with 3 devices, 3 screens, xinerama active etc... But I was totally unable to get 3 montitors to work. (I tried unplugging monitors, reconfiguring whole nvidia setup, ...)

But it gets even better:
When I restart my machine (i.e. choose the restart option from the Ubuntu menu) it shuts down and tries to restart. The restart then gets stuck after showing the Ubuntu splash screen with the 'loading bar' (the moving dots thingy) and I am forced to kill the machine by cutting power. But after the power cut the machine boots up normally and suddenly I get my 3 monitor setup back up working. That is until the next time I shut down and start up, where it all starts over again and I only have one monitor... (see above)

I really have a hard time seeing where the error is. It must be that the restart boot somehow differs from the 'normal' boot. But the fact that it gets stuck and I need to cut power which then basically triggers a 'normal' boot does not really support this theory...

My setup (please tell me if you need further info):

  • 3 monitors as 3 screens as one desktop (with xinerama)
  • 2 nvidia cards where screen 0 and 1 are on card 0 and screen 2 is on card 1
  • Ubuntu 10.04 Lucid Lynx (updated from 9.10, 9.04, ....)

I would appreciate every idea on the subject, at the moment I really don't have any clue what to do...

2 Answers 2


Try installing NVidia from nvidia.com , or try out the latest beta (256.xx) driver. About how to install it from scratch... >> Let me copy my answer from a different question.

Here is a great howto, step-by-step, easy-to-use.

But let me correct it out, regarding the 10.04 release !
First of all (before steps), download the "dkms" pack from the bottom of the post on the linked page, and the nvidia driver from nvidia.com into your home directory.
Step1, remove the drivers. Fix the "180" to "190" or "195" , don't sure how Ubuntu calls it at the minutre.
At step 2, edit /etc/modprobe.d/blacklist.conf . (Check if its modprobe.d/ , maybe it is called "blacklist.d" , I'm not sure about it (and can't check it at the moment), try both. Only one exists/works.) Add 2 new entries to the end:
blacklist nv
blacklist nouveau

Then do a reboot, at the boot menu, select recovery mode. Go with the "root mode with networking" (or what, its at the bottom, you will be able to identify it, don't worry about the instructions. :))

When it boots, type your root password. Then type: init 3 . Login again (yay).

Now, install the driver with sudo sh ./NV* . There will be an error about "distributor provided.." don't care about it, just agree, yes yes (more, grep, fsck :)).

After it finishes, do a sudo nvidia-xconfig . THEN, do the sudo sh ./installdkms* part. After it finishes, you are done, reboot.

Yeah I'm aware of the howto and how its 'harder' than the "install restricted modules". However, a lot of people noticed issues , anomalies with the default driver. This way you will get the NVidia binary driver, more recent than the one Ubuntu ships, and it won't be a problem during kernel upgrades. Also, you can upgrade the driver by hand whenever you want. If you get stuck, comment, ask. (Check which part seems to be hard , check if you can find that blacklist and such before you dive in.)


I have the same issue on 10.04, but with a Intel GM45 Express Chipset. I work around this annoyance by killing X (ALT + SqsRq + K), and logging in again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.