5

I have Android Studio 3.4.2 on Ubuntu 18.0.4 When I try to update it I get below error

error resolving packages

Package "Android Emulator" with revision at least 29.1.7 not available

I search for this error but I could not find any solution for it

did anyone has the same issue

Best Salem

1
  • Yes, I encounter the same problem. No idea, what is going on... would love to know a solution, too! Aug 18 '19 at 9:49
5

These are the steps that solved the problem for me:

  • In Android Studio, go to "Appearance and Behaviour - System Settings"
  • There, choose "Updates" and set "Automatically check updates for" to "Canary Channel" (Maybe sth else will do, too, but it seems that "Stable" would be the wrong choice)
  • Then switch to "Android SDK" -> "SDK Tools" and update the "Android Emulator" (which is the one thing that is not installed with the proper version)
  • When finished, switch to "Android SDK" -> "SDK Platform" and activate the "Show Package Details" checkbox (bottom right)
  • Under "Android 9.+ (Q)" the checkbox next to "Google API Intel x86 Atom System Image" can be activated (it should be a "-" at the moment).
  • After that, click "Apply"

The Download should start. If it is finished, it might be advisable to change back to the stable update channel (I did and so far there are no problems; the "Update" message disappeared).

Hope that helps!

Change update channel to something else then stable

Update Android Emulator

Update the Google APIs ... Atom ...

3
  • I just followed the same procedure but only clicked on check now for stable channel and it downloaded the required files. I did not shift to canary channel. Aug 23 '19 at 7:28
  • @MuhammadbinYusrat it didn't help me. The answer did though. Aug 23 '19 at 15:52
  • 1
    @SevastyanSavanyuk You can try shifting briefly to canary and immediately shift back to stable and it should download the needed files. Canary Channel will not always have the most bug-free sources and could cause more problems. Aug 26 '19 at 5:42
0

It appears that sometimes Android Studio will not show that there are updates available even when they are.

Combining the answer from Robert Wielding and the comment from Muhammad bin Yusrat above, here is the way to get it to recognise those updates.

  1. Check for Updates - it tells you there are no updates available.
  2. Go to Settings for Updates, switch to another chennel, eg Canary, and Check for Updates.
  3. Android studio says there is an update. Ignore it and switch back to Stable.
  4. Change to Android SDK. Now it mentions an updates "Android Emulator".
  5. Select it to change the tick-box to be selected.
  6. Select Apply.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.