0

Windows 7 won't sleep after high or max RAM usage

Steps that lead to problem:

  • Use RAM heavy program(s) (in my case: Blender 2.8, Chrome) that maxes out my RAM
  • Let the RAM usage drop back to normal
  • Wait 1, 2, or 3 hours, whatever
  • Try to put my computer to sleep

If RAM is maxed out even once while my PC is awake, the problem will occur on next sleep attempt.

As with many other no-sleep issues discussed on the internet, my monitors all go to sleep but my fans - GPU, CPU, Chassis, etc keep spinning.

I'm forced to either reset or hard power off my PC at the PSU switch.

This problem has happened across many different builds over a period of 5+ years.

I'm fed up.

  • I've tweaked all the usual suspects in advanced power setting options (yes, hybrid is off too).
  • I've taken a look at powercfg /requests right before attempting sleep, nothing there, still happens.
  • Drivers / Windows updates are always up to date.
  • Multiple antiviruses / firewalls.
  • S3 enabled in BIOS

Possible cause - and I'm hoping not to manipulate any answers by suggesting this - I've used Faronics DeepFreeze consistently throughout the problem. If you have any knowledge about DeepFreeze and think it might be the cause please point me in the right direction.

Specs:

  • Windows 7 Pro 64-bit (Consistent with the problem) (Multiple re-installations)
  • 32GB RAM (Currently) (16, 8, and 4 the last times. Doesn't really matter..)
  • Multiple CPUs - Intel, AMD
  • EVGA 2080 ti - Happens no matter what graphics card I use.
  • Multiple hard drives over the years - HDD, SSD - whatever
  • Multiple motherboards

Cheers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.