3

The error when clicking "Test Connection" within the project connection dialog is like this:

Connection to 'XXXXXX-ssh.services.easyname.eu' failed. Unable to reach a settlement: [diffie-hellman-group1-sha1, diffie-hellman-group-exchange-sha1] and [curve25519-sha256, curve25519-sha256@libssh.org, ecdh-sha2-nistp256, ecdh-sha2-nistp384, ecdh-sha2-nistp521, diffie-hellman-group-exchange-sha256, diffie-hellman-group16-sha512, diffie-hellman-group18-sha512, diffie-hellman-group14-sha256, diffie-hellman-group14-sha1]

Do you know that this error means and if there is some setting in IntelliJ to fix it?

3

I am having the same problem.

in .IntelliJIdea2019.2/system/log/idea.log I see

2019-09-22 13:43:58,474 [649136973]   WARN - z.sshj.transport.TransportImpl - Dying because - Unable to reach a settlement: [ssh-dss] and [rsa-sha2-512, rsa-sha2-256, ssh-rsa, ssh-ed25519] 
net.schmizz.sshj.transport.TransportException: Unable to reach a settlement: [ssh-dss] and [rsa-sha2-512, rsa-sha2-256, ssh-rsa, ssh-ed25519]
    at net.schmizz.sshj.transport.Proposal.firstMatch(Proposal.java:145)
    at net.schmizz.sshj.transport.Proposal.negotiate(Proposal.java:129)
    at net.schmizz.sshj.transport.KeyExchanger.gotKexInit(KeyExchanger.java:224)
    at net.schmizz.sshj.transport.KeyExchanger.handle(KeyExchanger.java:356)
    at net.schmizz.sshj.transport.TransportImpl.handle(TransportImpl.java:503)
    at net.schmizz.sshj.transport.Decoder.decodeMte(Decoder.java:159)
    at net.schmizz.sshj.transport.Decoder.decode(Decoder.java:79)
    at net.schmizz.sshj.transport.Decoder.received(Decoder.java:231)
    at net.schmizz.sshj.transport.Reader.run(Reader.java:59)

Apparently, this is because the client offer of [ssh-dss] and the server list [rsa-sha2-512, rsa-sha2-256, ssh-rsa, ssh-ed25519] don't intersect, so the protocol cannot agree on a mutually supported algorithm for ssh.

I followed the advice at https://intellij-support.jetbrains.com/hc/en-us/community/posts/360004370099-DataGrip-2019-2-RC-SSH-Tunnelling-no-longer-works to resolve this issue.

First, I found that I have the following in /etc/ssh/ssh_config

# Custom options from `extraConfig`, to override generated options


# Generated options from other settings
Host *
AddressFamily any

XAuthLocation /nix/store/mpa2k8as7sympa93rzvrvkmhrh6pnahi-xauth-1.0.10/bin/xauth


ForwardX11 no

PubkeyAcceptedKeyTypes +ssh-dss
HostKeyAlgorithms +ssh-dss

Then I added the following to ~/.ssh/config

Host *
    HostKeyAlgorithms rsa-sha2-512,rsa-sha2-256,ssh-rsa,ssh-ed25519

This fixed my problem.

  • Sounds good +1 I ll check – Blackbam Sep 22 at 14:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.