0

I am using iterm2 with tmux integration and I have two problems.

  1. I frequently have multiple panes in a single tab with one of the panes maximized. If I alt+tab out to, say, my browser, then when I come back to iTerm my maximized pane is automatically restored to its previous size. I find this behavior supremely annoying. How can I change it?

  2. If I create a new tmux session, detach from it, and then reattach to it from a larger display, the iterm2 window will refuse to fill the whole screen. I can zoom in, but I would like to resize the tmux session itself while keeping the zoom level constant. How can I do this?

2
  • The vanilla terminal has this problems? Why aren't you using the vanilla terminal? – 174140 Aug 21 '19 at 5:39
  • iterm2 has a lot of features that Terminal doesn't. – newmacuser Aug 21 '19 at 5:51
1

Agree this is annoying behaviour. I'm aware of two solutions (perhaps better described as workarounds) - either:

1) Enable Full Screen mode, or

2) Enable iTerm2 -> Preferences -> Appearance -> Tabs -> Show tab bar even when there is only one tab

Neither is perfect but there is no obvious way to avoid the resizing when the tab bar disappears.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.