1

I'm using 0-9 and A-Z to name files. For example, ex_1A, ex_23, etc. I pad to 2 digits, so 9 would be ex_09.

In Windows 10 File Explorer, it sorts things completely wrong:

ex_00
ex_0A
...
ex_0Z
ex_01
ex_1A
...
ex_1Z
ex_02
ex_2A
...
ex_2Z

and so on. Using dir /b "C:\PATH" lists things properly:

ex_00
ex_01
...
ex_09
ex_0A
...
ex_0Z
ex_10
...
ex_19
ex_1A
...
ex_1Z

and so on. I've tried turning off numerical sort with the group policy editor, but it does nothing. In explorer, I group by type and sort by name. It seems to be ignoring the padding 0, which completely defeats its purpose. Is there a way to fix this?

0

I see that you tried 'Turn off numerical sorting in File Explorer' in Group Policy Editor. That worked for me.

However, I noticed that this policy exists in both the Computer Configuration and the User Configuration branches. Which branch did you change?

For me, changing in the User Configuration branch solved the problem:

enter image description here

I did not change the Computer Configuration branch:

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.