0

I am reflashing my XPS 13 with Windows 10. I have booted other computers and its usually straight-forward with either UEFI or BIOS doing the trick. My computer is only booting when my live USB is flashed with BIOS (MBR) NFTS but once I am asked to install the Windows.iso to a partition, i am unable to as the partitions say they only allow GPT.

I reflashed my USB with UEFI (GPT) FAT32 and the computer provides an error displaying: "ERROR: LEGACY BOOT OF UEFI MEDIA This Drive can only boot in UEFI mode. If you want to boot this device in BIOS/Legacy Mode, you should recreate it with Rufus with the following settings: MBR, BIOS.."

I have tried each of the following: Legacy Mode, UEFI Mode, Secure Boot OFF, Secure Boot ON.

How do I get around to reflashing my laptop with windows 10?

BIOS Version: 1.7.0

  • This is a recent model. you should be able to install Windows UEFI with secure boot. Try with Windows Media Creation Tool instead of Rufus or burn it to a DVD using AnyBurn, ImgBurn, Nero or whatever. – Samuel Aug 23 '19 at 5:11
  • Get the tool here microsoft.com/en-us/software-download/windows10 – Samuel Aug 23 '19 at 5:12
  • Also, is there a reason why you aren't simply restoring this PC? Check support.microsoft.com/en-us/help/12415/…. Option 2) Restore and option 4) Restore with usb stick. – Samuel Aug 23 '19 at 5:19
  • I have tried: UEFI Mode with both Secure Boot OFF and then ON - it does not recognize the USB device in this mode, it only recognizes the live USB in Legacy Boot. I don't have a dvd to burn it to and I don't have a DVD dongle to be able to read it either. I also cannot restore the PC, the PC would stay stuck on the home menu and would react very slowly to mouse clicks (up to 5 minutes for a single mouse click) - I ran diagnostics on the laptop and it concluded to everything being healthy - first step was to reflash but i cant seem to do that because of the issues above. – dianaleeg Aug 23 '19 at 18:28
  • Im aware of that tool - I used it previously for other computers but the laptop isn't in a state where i can recover or restore. I need to find a way to be able to boot with UEFI - Im wondering if BIOS is out of date and doesn't allow boot with UEFI usb? Restoring with USB also resorts to the same issue as above. – dianaleeg Aug 23 '19 at 18:34
1

The EUFI Bios of the XPS shoudl be set to UEFI, Secureboot OFF and Legcay Mode (or CSM as it is also called) disabled.

On another computer use the Microsoft Media Creator tool to download a fresh ISO and write it to the USB. Don't mess with the USB formatting and/or partitioning yourself.

That newly written USB should work.

| improve this answer | |
  • SecureBoot needs to be enabled for Windows 10 on UEFI motherboards. Why are you recommending for it to be disabled?. – JW0914 Jan 23 at 14:41
  • 1
    @JW0914 It is not required, but recommended. But some computers seem to really not like it when booting from USB (even when using an official Microsoft image) and boot just fine with SecureBoot off. You can always re-enable it AFTER Windows has been installed. By teh way: For a Rufus based USB NTFS stick you will HAVE to switch it off anyway, because the Rufus NTFS EFI driver isn't signed. – Tonny Jan 23 at 14:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.