0

I am working at Computer A and starting a non-fullscreen Microsoft RDP session to computer B (both Windows 10 Pro). When I take a break I press Win+L on Computer A and lock my session. When I return I need to log back into both machines: The Lock gets forwarded to computer B. This also happens when:

  • I target another application on Computer A before locking
  • I lock using the Start Menu -> Profile icon -> Lock Session, not the key combination
  • When I use Devolution's Remote Desktop Manager (where I can access a lot more options)

It doesn't happen when:

  • I don't lock Computer A when taking a break (that is: It's not a timeout thing)

I was wondering if there was a way to avoid this Lock to be forwarded. Regardless of whether I SHOULD, I am not looking for WHY Windows does this (but you are free, of course, to still explain, it's the Internet, I can't stop you :) )

  • @Tetsujin That's literally the first case I mention in my "this also happens when" list. So: Yes. – Vincent Vancalbergh Aug 23 '19 at 8:39
  • Does it happen even if you lock Computer A and login right after? Or must take some time? – Ronaldo Aug 23 '19 at 11:44
  • @Ronaldo it happens immediately. – Vincent Vancalbergh Aug 23 '19 at 14:24
0

One way to stop this behaviour is to disable the lock option of computer B. Won't avoid the lock to be forwarded, but it will not take effect on the remote computer. If it fits for you, here's how it's done:

Run regedit and navigate to the following key: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System (if you don't have the System key, right click and create it).

When in the System key, on the right side of the window, right click > new > DWORD and name it DisableLockWorkstation.

Now right click DisableLockWorkstation and change the Value Data to 1. You're done! You might need to restart the computer once before it works (although mine didn't need to).

Font: How to Disable the Lock Screen Shortcut Key (Win + L) in Windows

  • Unfortunately I still need the lock feature on computer B (it's my work laptop and I regularly need to lug it around for meetings and such, I just RDP to it from my desktop when at home). It's also managed by my work's domain, so I probably won't be able or allowed to change it. – Vincent Vancalbergh Aug 23 '19 at 14:19
  • I see. @VincentVancalbergh, I just noticed that when I chose to show options on the RDP connection window where you enter your credentials there's the tab local resources in which you have some keyboard options. Have you tried to change these settings? – Ronaldo Aug 23 '19 at 20:24
  • 1
    One more thing: you mentioned the laptop is managed by the work's domain, maybe that's a domain config since I also RDP my computer at work and the remote connection doesn't lock when I lock my local computer. Could you contact your domain admin to check it? – Ronaldo Aug 23 '19 at 20:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.