-1

I use Windows 10, Laragon, Apache and Filezilla FTP server for my server.

It was working when my Apache was on HTTP but when I turned it to HTTPS with this code:

    <Directory "C:/laragon/www/">
        AllowOverride All
        Require all granted
    </Directory>
</VirtualHost>
<VirtualHost _default_:443>
    <Directory "C:/laragon/www/">
        AllowOverride All
        Require all granted
    </Directory>

    SSLEngine on
    SSLCertificateFile      C:/laragon/ssl/certificate.crt
    SSLCertificateKeyFile   C:/laragon/ssl/private.key
    SSLCertificateChainFile C:/laragon/ssl/ca_bundle.crt
</VirtualHost>

My client side can't connect to the server and it doesn't return to me any errors, it just puts me in an endless of loop trying to connect.

My client (ftp-kr on VS Code) results:

https://i.imgur.com/UfWQHdx.png

My Filezilla FTP server log:

https://i.imgur.com/VeAQqUD.png

Both ports 21 and 990 are open. I tried this with port 21 and the results are the same.

My client config:

{
    "host": "95.216.111.51",
    "username": "danial",
    "password": "*******",
    "remotePath": "/",
    "protocol": "ftps",
    "port": 990,
    "fileNameEncoding": "utf8",
    "autoUpload": true,
    "autoDelete": false,
    "autoDownload": false,
    "ignore": [
        ".git",
        "/.vscode"
    ]
}

My Filezilla FTP server SSL config linked to Apache SSL certificates:

https://i.imgur.com/nrVAHiW.png

  • 1
    Whatever you do in Apache has no effect on your FTP server. You need to look at the FTP client’s full output to get the required information. The client decides to disconnect, after all. – Daniel B Aug 23 at 7:54
  • I was check it its work whit out apache ssl – Danial Qsk Aug 23 at 8:31
1

The problem you are experiencing is unlikely to be related to the changes in Apache you reference.

What seems more likely is that your FTP client isn't handling the Filezilla FTP server settings you have specified well. Specifically, the option to Require TLS session resumption on data connection when using PROT P may be causing your issue. You should try turning it off:

ex. Disable Filzezilla TLS Session Resumption With PROT P

Disable Filzezilla TLS Session Resumption With PROT P

Once you have unchecked the option above, don't forget to press OK to apply your changes before attempting to connect again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.