0

I set up an OpenVPN server, using this command:

sudo openvpn --config OpenVPN/England-TCP.ovpn

And if I then check my IP using this command:

curl ifconfig.me

I can see that the IP has indeed been changed. I can also see that Telegram (which is censored in my country) is working properly when I tell it to "use system proxy settings."

And If I search "my ip" in DuckDuckGo or look it up from sites like https://whatismyipaddress.com/, I can see that IP has been changed.

But, I still cannot access sites like Twitter, YouTube (which are censored in my country)

Twitter opens, but stays like this:

enter image description here

And Firefox shows this for YouTube:

enter image description here

How can I fix this?

The content of England-TCP.ovpn contains certificate keys, so I'm not sure if I should share it online, but these line might be relevant:

client
dev tun

remote uk.ovadd.com 443 tcp

persist-key
persist-tun
resolv-retry infinite
route-metric 1

nobind
pull

verb 3

auth-user-pass

I use Arch Linux, and my system's using 192.168.1.1:

╰─ nmcli dev show | grep DNS
IP4.DNS[1]:                             192.168.1.1

Also, here's the output of ip addr:

╰─ ip addr                                                                                                 ─╯
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp4s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 54:42:49:ec:36:64 brd ff:ff:ff:ff:ff:ff
3: wlp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 4c:0f:6e:df:2e:3e brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.5/24 brd 192.168.1.255 scope global dynamic noprefixroute wlp2s0
       valid_lft 75921sec preferred_lft 75921sec
    inet6 fe80::5aed:4888:9ec5:ce88/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
8: tun0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN group default qlen 100
    link/none 
    inet 10.7.2.146 peer 10.7.2.145/32 scope global tun0
       valid_lft forever preferred_lft forever
    inet6 fe80::341b:f484:9cd1:a004/64 scope link stable-privacy 
       valid_lft forever preferred_lft forever

I changed the DNS settings of my Network to 8.8.8.8 (or even 1.1.1.1) like this:

enter image description here

And reconnected so that:

╰─ cat /etc/resolv.conf                                                                                   
# Generated by NetworkManager
search Home
nameserver 192.168.1.1
nameserver 8.8.8.8

But everything is still the same.

4
  • What DNS servers are you using, and what kind of errors do you get when going to a blocked page?
    – davidgo
    Aug 25 '19 at 7:38
  • @davidgo I edited the question to show the errors. How can I check which DNS servers I'm using? Aug 25 '19 at 7:46
  • What OS? Few Windows open a cmd window and type "ipconfig /all"
    – davidgo
    Aug 25 '19 at 7:51
  • @davidgo Sorry, should've mentioned it in the beginning, edited. Aug 25 '19 at 8:02
0

The issue is likely your DNS. The specified DNS server is on your LAN, and most likely your router. Traffic to your router does not go across your VPN and is likely getting its DNS answers from your ISP, who is likely not returning the correct result.

A solution would be to change your DNS servers to something not local - like 1.1.1.1 (Cloudflare) or 8.8.8.8 (Google).

I dont use Arch, so you may need to Google it, but many Linux distros allow you to specify DNS in /etc/resolve.conf (Insert a line "nameserver 8.8.8.8" above any other nameserver entries, and edit file as root). YMMV though as this is likely overwritten by DHCP.

Another possibility could be to change the DNS server your router hands out to DHCP clients (many routers support this) or to change to using a static IP address on your computer so DNS servers arnt overwritten - or use your distro-specific workaround.

2
  • Changing DNS server to 8.8.8.8 or 1.1.1.1 didn't work, edited my question on how I changed it. Aug 25 '19 at 9:57
  • Remove 192.168.1.1 as nameserver and tell me what happens. Also, you may want to Google "changing nameservets arch linux" or post it as a separate question.
    – davidgo
    Aug 25 '19 at 19:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.