0

I want to copy my website to the webserver. These files should be transferred from my local computer to my Windows server. I am running Windows 10 version 1709 (build 16229.431) on my local machine and Windows Server 2019 version 1809 (build 17763.348) on my webserver. Both machines have a static IP. On both machines GIT version 2.15.1.windows.2 on the local machine and GIT 2.23.0.windows.1 on the web server.

So far, I have been copying the files (Ctrl+C, Ctrl+V) via Remote Desktop to the Windows Server. Is there a way to solve this using a PowerShell command or similar? Or somehow with GIT?

I have tried WinSCP, but that didn't work because I couldn't get to the web server. I don't think the solution of copying via RDP is smart.

  • What was the problem when you tried to use WinSCP? – YetAnotherRandomUser Aug 27 at 14:24
  • I could not connect to the server with Winscp. – Ali Aug 27 at 19:32
  • This is the exact error: "Network error: Time limit for connection "xxx.xxx.xxx.xx" was reached." – Ali Aug 27 at 19:35
  • I'm guessing that you didn't set up or test an FTP server on your webserver. You'll need to do that to get FTP working. I use FileZilla for server and client, and it's relatively straightforward. There might be a way to use http, but that's a lot more complicated than install Filezilla, make a user, connect with that user. – YetAnotherRandomUser Aug 27 at 22:25
0

I made it. I can now always get the correct version from the repository via GIT. The problem was that the Windows firewall did not allow access from my GIT server. Now I released the web server on the GIT server for incoming and outgoing connections. Now it works. Thanks to everyone who tried to help me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.