2

I am installing SQL Server 2012 in my computer but this error message always shows up. I tried installing it in a Virtual Machine, and it worked! Other threads says that the issue is permission access, but I've already allowed access and I'm using an admin account. I also tried cleaning up my temp folder files, nothing still. Hope someone could help me resolve this problem. Thanks!

PS. I am using Windows 10 Pro

`TITLE: SQL Server Setup failure.

SQL Server Setup has encountered the following error:

Unable to generate a temporary class (result=1). error CS0016: Could not write to output file 'c:\Users\jdaquino\AppData\Local\Temp\mcxybaib.dll' -- 'The process cannot access the file because it is being used by another process. '

Error code 0x84B10001.`

enter image description here

  • Please, add the version of Windows you're using. – Ronaldo Aug 28 '19 at 12:23
0

You can use ProcMon to identify the other process using the file.

enter image description here

My suggestion is to also change the default account that start the services to "Local System", to a local administrator account or to a domain account. Below the setup page where I suggest you to change the default service accounts.

enter image description here

Please follow this step-by-step tutorial on how to install SQL Server 2012.

Disable antivirus software.

Change the language of the operating system in Control Panel to English US (Control Panel - Region - Formats Tab - Format -> English (United States))

|improve this answer|||||
  • Hi. Thank you for responding. I tried to use the ProcMon but the file wasn't there. As for your second suggestion, I cannot even get to the Setup window, because every time I open the setup.exe, it displays that error message. Additional info: The .dll file changes everytime that error shows up. – Jmarco29 Aug 29 '19 at 7:55
  • Do you have any Antivirus software installed on that computer. Could you please try to disable it or uninstall it? – Alberto Morillo Aug 29 '19 at 11:11
  • I only have Windows Defender installed. I tried to disable it and run the setup.exe again. The result was still an error, but a different one. See link: imgur.com/a/X6u6wNM | BUT THEN, I run it the second time, and my original error message shows up again. – Jmarco29 Aug 30 '19 at 6:49
  • Change the language of the operating system in Control Panel to English US (Control Panel - Region - Formats Tab - Format -> English (United States)) – Alberto Morillo Aug 30 '19 at 13:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.