0

When I first set up my computer, I had ATI cards in it. Those have since died on me and I'm using an Nvidia card as a replacement. Since installing the Nvidia drivers, Waterfox and ONLY Waterfox has its window contents shifted up slightly. If I uninstall/disable the drivers, the issue goes away. Another reason I know that it's just a graphical issue is that I have to adjust where I click in Waterfox down slightly to interact with it properly. If I go fullscreen with anything, (the browser window, video, browser game), it works fine again. Windows GUI elements seem to be fine, the menu drop downs work properly as well as the Save As dialog box. Anyone know how to fix this, or possible troubleshooting steps to diagnose what's going on with this?

Thanks.

Troubleshooting/Observations:

  1. It's not a scaling issue as that doesn't fix the problem.
  2. Not an addon issue since disabling them doesn't work.
  3. Disabling drivers fixes issues.
  4. Affects multiple versions of graphics cards and drivers. 700 series and 900 series. Only one used at a time.
  5. Only Waterfox has this issue.
  6. Executable profile in the Nvidia settings doesn't seem to do anything, though I may not have gotten the right settings.
  7. ATI drivers were uninstalled.
  8. Waterfox is up to date.
  9. Latest drivers for Nvidia don't fix it.
  10. Menus and other dialogs are in the proper places and are visually correct.
  11. History/Downloads/Bookmark window, and the bookmark update window have the same issue, so this happens to all of Waterfox.

Here's a pic of what is going on: enter image description here

EDIT: Disabling hardware acceleration resolves the issue. Disabling WebGL in the config options does not though.

EDIT 2: Using dirdi's answer, I was able to find an option to disable using OpenGL with Waterfox. It's using DirectX now, and I have no black bar. This issue seems to affect both Firefox, (Waterfox is just a rebranded, old GUI Firefox), and Chrome. The Driver WSI Info listed in about:support all state that Google is the vendor for the WebGL drivers, so it's potentially something wrong in their driver. I've seen that Chrome can also have this issue with Hardware Acceleration enabled at times. What lead me to find this was the following in about:support

OPENGL_COMPOSITING  
disabled by default: Disabled by default   
available by user: Enabled via layers.prefer-opengl  

What's kinda odd is that it was set to true, and I set it to false, so I don't know if I enabled it or disabled it.

  • 1
    Have you checked if there are errors / warnings if you run waterfox from command prompt (Win-Key + cmd + Enter)? You could also check it there is something unusual within the about:support tab. – dirdi Sep 8 at 10:03
  • No messages in the command prompt at all. The troubleshooting screen did lead me to this: OPENGL_COMPOSITING disabled by default: Disabled by default available by user: Enabled via layers.prefer-opengl And disabling it removes the black bar. – Blerg Sep 9 at 10:46
  • @dirdi It's using DX instead of OGL, so I have hardware acceleration and no black bar. If you make an answer, I can at least award the bounty to you since this helped me resolve the issue. Ends in less than two days though. – Blerg Sep 9 at 10:52
  • Glad I was able to help you resolving the issue. I tried to transformed my comment into a good answer, but since actually you solved the issue, please feel free to edit it and add more information. – dirdi Sep 9 at 11:59
1
+50

I suggested doing some more troubleshooting to gather more information and to isolate the problem:

  • Check if there are errors / warnings if you run waterfox from command prompt (Win-Key + cmd + Enter)?

  • Is there something unusual within the about:support tab?

The about:support tab revealed that WaterFox is using DirectX instead of OpenGL and ths issue can be resolved by disabling hardware acceleration: OPENGL_COMPOSITING disabled by default: Disabled by default available by user: Enabled via layers.prefer-opengl

  • Thanks again for your help with this. It doesn't seem like it's specific to Waterfox. – Blerg Sep 9 at 13:01
0

WaterFox uses Reddit for bug reporting. Please report the issue there. The developer can't fix the problem if it's not reported. You might find that it's a known issue they are working on.

https://www.reddit.com/r/waterfox/

You can also make an Issue on their GitHub: https://github.com/MrAlex94/Waterfox

Or if you're feeling ambitious, you could fix the problem yourself and issue a pull request to that GitHub. It is open source, after all.

0

Waterfox could still remember the previous graphical card and still keep some settings that cause this problem with the new cards.

I would advice to uninstall Waterfox, scrub from the disk any folder that mentions "Waterfox", then reinstall the latest version of Waterfox.

If this does not work, this is then a general problem of Waterfox, so you could post the problem in the Waterfox Community Support.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.