0

I am trying to FTP into an AWS EC2 Linux AMI server from Atom's Remote FTP application.

I keep getting the error which I have spent many countless hours trying to figure out what is the cause of

Could not parse .ftpconfig: Unexpected token U in JSON at position 213

I tried "protocol": "sftp", and tried the file location with a single \ instead of \\ but still of no luck. Here is the protocol request I am making. Greatly appreciate your help.

{
    "protocol": "sftp",
    "host": "ec2-3-17-26-85.us-east-2.compute.amazonaws.com",
    "port": 22,
    "user": "ec2-user",
    "pass":  "",
    "promptForPass": false,
    "remote": "/",
    "privatekey": "C:\\Users\\Jessica\\AppData\\Local\\atom\\app-1.33.1\\php_webserver.pem",
    "local": "",
    "secure": false,
    "secureOptions": null,
    "connTimeout": 10000,
    "pasvTimeout": 10000,
    "keepalive": 10000,
    "watch": [],
    "watchTimeout": 500
}

If I understand correctly, the ftpconfig is a JSON file and therefore it needs the double \\ to specify a single \.

I should also point out that Port 22 is also the same port I use to SSH. I am not sure if this is an issue, that is, using the same port to both SSH and FTP.

Update

I was able to fix the issue but now I am getting a Timeout connecting to the server.

Remote FTP: Connection failed
Error: Timeout while connecting to server

I believe the issue is linked to the server accepting an FTP in 'Active Mode' mode as while Remote FTP being in 'Passive Mode'

https://github.com/icetee/remote-ftp/issues/306#issuecomment-273719079

Anyone know how to switch the setting in Remote FTP on Atom?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.