1

I have tried to install the 1903 Win10 (Home) update on my PC. After a while it said that a restart was needed so I did that. Now it won't complete the set-up process and I can't boot the PC.

During boot the windows logo appears, then is replaced by a black screen with a spinning icon.

This basically stays forever. Although I get the occasional indication of disk activity (once every 2 seconds or so), the PC appears to be doing nothing. It is running very quietly and not generating any noise or heat.

I have booted from a Win10 installation disk into the advanced recovery options, but nothing here works. I just get errors.

It does not find any recovery partition. System restore says "you must specify which installation to restore" (but I have no options) Start-up repair says "could not repair your PC" Uninstall feature updates says "We ran into a problem"

Via command prompt them sfc /scannow shows no errors bootrec.exe /fixmbr says "completed sucessfully" bootrec.exe /fixboot says "access denied" bootrec.exe /rebuildbcd shows me an option [1] c:\windows I say "Y" and then it says "The requested system device cannot be found"

I am at a loss on how to fix this problem other than wiping the disk and starting again, which I am reluctant to do and it will take me ages to restore all my data.

Any ideas? What can I do?

  • It sounds like your system drive suffered a hardware failure, and you just happen to be in the process of performing an upgrade to 1903, what you describe is a classic sign of a disk problem. Healthy system disks, with an installation without any corruption, do not do what you describe. – Ramhound Aug 29 '19 at 19:15
1

So I have managed to do execute a system restore!

After spending a few hours over the past few days on this I again tried the advanced system restore menu and this time the system restore allowed me to select a windows installation and a restore point. So this was able to return my system to the previous state and it now works again.

I don't really know what I have done, I assume that executing the Bootsec.exe commands another time somehow this time fixed something, as otherwise I haven't done anything.

Now I need to decide what to do about the upgrade, as it has been recommended to me by my motherboard manufacturer (Gigabyte) due to a problem I have with my MB.

|improve this answer|||||
  • 1
    This is a list of all issues with 1903. Sounds like your system currently isn’t compatible with 1903. – Ramhound Aug 30 '19 at 5:59
  • My machine is only a few months old with all new components (except graphics card, which is still good and supported). So there shouldn't be an issue. And I can't find anything specific on this list. – jason.kaisersmith Aug 30 '19 at 6:38
0

If you did not make a disk image before installation, then your best bet is to boot from USB drive, e.g. WinPE or Linux distro, save as much of the disk as feasible, particularly your data and possibly program files that do not require installation, such as Notepad++.

Now you can attempt to completely reinstall Windows 10 (whether v. 1809 or v. 1903, which appears to be "a work in progress") from ISO, restoring your data and some programs. Of course, programs with elaborate installation, such as Visual Studio, will need to be reinstalled. Some, such as 7-Zip, work without installation, but will not be integrated into Explorer context menus. Applications such as Mozilla Thunderbird and Firefox require simple installation, and then your user profile saved from the original in your user data can be restored over the newly generated profile, so nothing is lost.

In the future, make a disk image before major updates to avoid this hassle.

|improve this answer|||||
  • The ability to perform an upgrade, and keeping your files, requires the author to start the upgrade from within Windows. If you boot to WinRE and/or an Windows ISO that option cannot be used. – Ramhound Aug 29 '19 at 19:13
  • If the author decides to perform that install, by booting to WinRE, the existing installation should be migrated to Windows.old. However, this assume the author does not, delete any partitions during the installation process. – Ramhound Aug 29 '19 at 19:30
  • In the past, MS has accidentally deleted files on update, e.g. answers.microsoft.com/en-us/windows/forum/windows_10-update/… . First make a disk image, e.g. with Macrium Reflect, which uses WinPE, then reinstall. – DrMoishe Pippik Aug 30 '19 at 4:16
  • 1
    That article does not apply to the author’s situation – Ramhound Aug 30 '19 at 4:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.