0

Just as a bit of a clarification, I have installed Linux on laptops in the past, as well as having a decent amount of experience using Linux distributions in VirtualBox, and I haven't seen this before. (Small edit: I have also managed to, without any problems or weirdness at all, install Ubuntu as my operating system instead of Windows 10. I have saved my Windows 10 product key in case I need it later though. For some reason, Ubuntu is the only distributions which has worked.)

When I boot into my live USB, what I expect to see is the Parrot OS specific version of the installer page. It should have images and text and look all pretty. This is what I expect to see in a healthy boot.

  • What I expect to see when I boot a Parrot OS live USB:

image

But instead, what I see is a very old-looking Grub screen which has the correct menu text, but doesn't have all of the things I otherwise expected to see. (I realize that these images and things don't really matter, but this is the main way I thought something might be going wrong).

  • The plain-blue-screen-with-text menu:

image

I then select live from the menu in order to boot into a live version of Parrot, and I see this error: NVME0: missing or invalid SUBNQN field. I'm also attaching a photo of the boot message in case that's not the key message I should be looking at.

  • NVME0: missing or invalid SUBNQN field:

image

After this, the installation essentially freezes. Sometimes I can type text into a small white bar at the bottom of a pure blue screen, but that's it.

Also, if I leave it alone after clicking live, I will be given a cmd called BusyBox v1.30.1 (Debian 1:1 30.1-4) built-in shell (ash) with a prompt called (initramfs). When I type help to get the commands available, I am shown the following:

. : [ [[ alias bg break cd chdir command continue echo eval exec  
exit export false fg getopts hash help history jobs kill let  
local printf pwd read readonly return set shift source test times  
trap true type ulimit umask unalias unset wait
(initramfs)_

I just also noticed another thing which pops up with the BusyBox.

BOOT FAILED!
This Live System image failed to boot.

Please file a bug against the 'live-boot' package or email the Live Systems mailing list at <debian-live@lists.debian.org>, making sure to note the exact version, name and distribution of the image you were attempting to boot.

The file /boot.log contains some debugging information but booting with the debug command-line parameter will greatly increase its verbosity which is extremely useful when diagnosing issues.

live-boot will now start a shell. The error message was:

   Unable to find a medium containing a live file system

After which the BusyBox shell mentioned earlier is started. I can't figure out how come the live image can't be found, as the ISO was attempted to be booted live.

I used the dd operation and got a different error this time. It relates to the ACPI issues mentioned in the comments. Here is a picture.

image

Any help would be appreciated, I am really hoping to get Parrot working on my laptop.

Thank you!

UPDATE: I haven't gone back to update the BIOS. I discovered that various flavors of Ubuntu work without issue on my hardware, and to prevent any screw-ups, I was content with that. It is interesting though, that Ubuntu is, as far as the distros I've tested, is the only one that works on my hardware. I expect it has something to do with the Ubuntu kernel being different than base Debian, since Debian itself also gives the errors described above. Distros I've tried are: Debian, Arch, Parrot, Ubuntu. I believe I tried a few others as well, but it's been long enough I don't remember anymore.

  • Searching "nvme SUBNQN" brings up some hits. Someone says a BIOS update helped. But the error-lines don't relate to that, to me the issue might be ACPI related. The interesting lines at the top are cut off, though. – nyov Aug 30 '19 at 6:44
  • Is there any way to dump the boot output to a file? The majority of the boot stuff gets cut off the top of the screen. Also, since my laptop is brand new (purchased this week), should I expect that I need to do a UEFI update? – nathaniel.graham Aug 30 '19 at 18:09
  • I've added a small edit near the top in parentheses. I don't know if it's relevant, but it seems the kind of information that might be. – nathaniel.graham Aug 30 '19 at 18:18
  • Update: It seems it might have something to do with the installer / boot cycle not being able to see the mounted drive right away. When running the installer instead of the live usb, I get an error stating "No common CD-ROM drive was detected." I have found a potential solution which I have yet to try (due to not wishing to royally screw something up without guidance) stating that I should back out into the installation options, open a shell, and then use mount -t vfat /dev/sda1 /cdrom and after that, try again and it should work. (In my case, it would be nvme0p1 I'm assuming due to using PCIe – nathaniel.graham Aug 30 '19 at 19:59
  • See that ACPI prediction I made - the new screenshot validates it: ACPI BIOS Error (bug): Failure creating ... Try to grab the latest BIOS update first, before wasting time on anything else. – nyov Aug 30 '19 at 21:08
0

The added photo shows an ACPI BIOS error message. ACPI are the basic routines and API that the OS uses to work with the hardware: device detection and configuration, power management.
If it's buggy, stuff doesn't work.
Getting a BIOS update, with hopefully fixed ACPI tables, is the best first step.

And then, Linux can work around a lot of such bugs, or even install completely new tables. That means it can depend on your linux kernel version if there is a workaround or not (which is probably why your Ubuntu distro worked, but Parrot doesn't seem to). Trying the latest kernel is a fine second step.

As the previous link explains, ACPI tables can be upgraded via initrd, that also means different distributions can ship their own and different bugfixes and Ubuntu has a very widespread hardware user-base, so possibly the most diverse workarounds.

In order of effort, you could try to

  • just use Ubuntu
  • run Parrot with an Ubuntu kernel ;) (Parrot is a Debian derivative)
  • find the specific workarounds in Ubuntu and port them (or ask parrot maintainers to help you there) to your Parrot kernel/initrd. The acpi debugging tools on the earlier link will help with that.

Personally, I would consider going with Ubuntu, as it apparently works on the hardware. All the same tools that Parrot/Kali/... can bring you are most likely packages from the Debian base anyway and will also be available for install from the Ubuntu repositories. With enough effort, you could even make your Ubuntu look like Parrot, or even better, something that looks and works best for you.

(I certainly never had to switch from debian for the reason that another distro had some software I wanted, and I think a lot of people install these distros more for bragging rights than actual need.)

| improve this answer | |
  • Thanks for the reply! I'm well aware that all three are debian, and in that way are cross compatible. What I'm not sure of, however, (due entirely to this being the first time I try to have a laptop completely dedicated to Linux) is if external tools and drivers would be available (the drivers for pentesting wireless cards for instance). My other thought is that it's rather curious that Ubuntu was able to install without hitch, while every other distribution I've tried fails in exactly the same manner. You're absolutely right though, I could simply install all of the tools from Kali/Parrot – nathaniel.graham Aug 30 '19 at 23:09
  • If I were to upgrade the ACPI tables with initrd, is there the posibility of accidentally soft locking my computer? Note, I'm not worried about losing data, as I don't have any personal data yet on the computer, I just don't want to lose the laptop. – nathaniel.graham Aug 30 '19 at 23:11
  • @ngraham20, no, the ACPI tables in initrd would be patched at boot time, every boot. Worst case you need to hard-reset your computer. Wireless card drivers may be more plenty in Parrot, though I don't think so, as Ubuntu probably has a lot more "desktop"-users complaining about their new hardware not working and thus getting it supported. – nyov Aug 31 '19 at 0:32
  • @ngraham20, it really is curious that only Ubuntu would work - but they are most aggressive in getting hardware supported, where debian (and by relay their other derivate distros) might complain about non-free and closed source binary blobs. IMHO. Also their release-cycle is simply shorter. – nyov Aug 31 '19 at 0:35
  • that makes sense! I've also noticed though that Kali doesn't work either. Is that because it's based on the Debian architecture, whereas Ubuntu is like a Fork of it or something? I remember seeing that somehow Ubuntu does something a bit different, but maybe I misunderstood. For now, I'm happy to use Ubuntu and use MATE and just manually install the programs I need. I'll stay pretty active on this thread though if I see other ideas or if one of my professors can walk me through the nitty-gritty of the table installation you mentioned so I don't mess up. Thanks again! – nathaniel.graham Aug 31 '19 at 0:46
0

You can try to add acpi=strict option to kernel command line.

This issue was discribed in debian wiki InstallingDebianOn

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.