0

Setting up my mac for local flutter development. I did all steps as mentioned in the guide, installed Android Studio and also updated the sdks. Here is what my flutter doctor -v says:

user$ flutter doctor -v
[✓] Flutter (Channel stable, v1.7.8+hotfix.4, on Mac OS X 10.14.5 18F132, locale en-IN)
    • Flutter version 1.7.8+hotfix.4 at /Users/yeshwanths/flutter
    • Framework revision 20e59316b8 (6 weeks ago), 2019-07-18 20:04:33 -0700
    • Engine revision fee001c93f
    • Dart version 2.4.0

[!] Android toolchain - develop for Android devices (Android SDK version 29.0.2)
    • Android SDK at /Users/yeshwanths/Library/Android/sdk
    • Android NDK location not configured (optional; useful for native profiling support)
    • Platform android-29, build-tools 29.0.2
    • ANDROID_HOME = /Users/yeshwanths/Library/Android/sdk
    • Java binary at: /Applications/Android Studio.app/Contents/jre/jdk/Contents/Home/bin/java
    • Java version OpenJDK Runtime Environment (build 1.8.0_202-release-1483-b49-5587405)
    ✗ Android license status unknown.
      Try re-installing or updating your Android SDK Manager.
      See https://developer.android.com/studio/#downloads or visit https://flutter.dev/setup/#android-setup for detailed instructions.

[✓] Xcode - develop for iOS and macOS (Xcode 10.3)
    • Xcode at /Applications/Xcode.app/Contents/Developer
    • Xcode 10.3, Build version 10G8
    • CocoaPods version 1.6.1

[✓] iOS tools - develop for iOS devices
    • ios-deploy 1.9.4

[✓] Android Studio (version 3.5)
    • Android Studio at /Applications/Android Studio.app/Contents
    • Flutter plugin version 38.2.3
    • Dart plugin version 191.8423
    • Java version OpenJDK Runtime Environment (build 1.8.0_202-release-1483-b49-5587405)

[✓] IntelliJ IDEA Ultimate Edition (version 2019.2.1)
    • IntelliJ at /Applications/IntelliJ IDEA.app
    • Flutter plugin version 38.2.4
    • Dart plugin version 192.6262.58

[!] Connected device
    ! No devices available

! Doctor found issues in 2 categories.
user$

So I googled up and found these links:

Tried all of them but none if them could solve it, when I tried flutter doctor --android-licenses I get this error:

A newer version of the Android SDK is required. To update, run:
/Users/yeshwanths/Library/Android/sdk/tools/bin/sdkmanager --update

But I did download the Android Studio and SDK from Android website today only. This is very confusing. Can someone advise on this?

1

I am also facing the same problem. I tried all possible ways but nothing worked for me. The only solution left is to downgrade java version.

0

You could try to specify the android-studio-dir with flutter config --android-studio-dir /path/to/android-studio to configure the path to your android studio, after that run flutter doctor --android-licenses and you should be able to accept the licenses.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.