I'm using Windows 7. All of a sudden, a couple of hours ago, this happened:

My keyboard number keys [above the letters] stopped working properly, both as numbers and as symbols. Only 5 and 6 are functional. Also, I've noticed that the End key isn't working either, and perhaps a couple more from that group.

I'm pretty sure it has something to do with those evil Sticky Keys/Filter Keys/ whatever those ease of access things are, BUT I've turned off all the ease of access keyboard options and nothing has changed. Is it possible that something is still turned on while I unchecked it? Are the on/off checkboxes to control WHEN it happens or IF it happens? I also tried rebooting and uninstalling/reinstalling keyboard from device manager, to no avail.

It's certainly a software issue and not a hardware issue, as I've tried another keyboard and the problem persists. And, predictably enough, it's annoying. Any ideas?

  • Please tell us your computer system and type/brand of keyboard.
    – kmarsh
    Aug 17, 2010 at 12:49
  • Try a different keyboard. Apr 3, 2012 at 23:12

11 Answers 11


Holding down the Right AltGr+Right Ctrl+Windows key got the keyboard working again for me when text/number keys weren't functioning at the login screen.

  • This fixed it for me too. Weird! Jul 27, 2015 at 1:24
  • Don't know how but it solved my problem too. I also hold left side ctrl + alt + win keys after right side keys. Windows 10 is OS and Sony Vaio laptop
    – Tanmoy
    Nov 8, 2016 at 6:42

I've had the same problem, weirdly on both our main and laptop computers, within a week of each other. was getting really annoying, kept getting locked out as passwords didn't work, couldn't enter credit card details (maybe no bad thing.... perhaps my husband set it on purpose)

Read all the answers, and figured it's just some key combination that possibly the kids have pressed (or me in a strop!). Tried the things suggested - and finally just pressed as many keys as possible (both hands) and what do you know? I'm back in business! I'm sure people who know stuff about computers will be horrified and maybe my computer will self destruct in 5 seconds, but it's good for now!


We just had this ourselves with a Win 7 NetBook - number keys don't work except for 5 & 6.

It turned out to be a Trojan Horse infecting Explorer and it could be traced to a bogus ADOBE upload or patch in Explorer. Look for a misnamed ADOBE.COM directory in Program Files or Windows and delete it. It has been attached to Explorer as it seems to be a nuisance only in that program.

We wonder if this came in as a result of loading Ad-Aware or due to some gaming sites my young son goes to. Finally, we just did went back to a previous system restore point - but it has been persistent - and annoying...

  • Wow! Uninstalling adobe flash worked! My 5 and 6 keys would quit working for a while and then work again. Did not want flash installed anyways. May 22, 2021 at 23:03

Uninstall drivers in Device Manager. Scan For New Hardware This will re-install the drivers and should fix the issue; it worked for me.

  • I had the problem of the upper-row five key, only, not working. NumPad 5 worked OK. The upper-row five failed with the laptop's built-in keyboard, with a USB keyboard, and even with the Windows on-screen keyboard. That says the problem must be in the OS, and not in the hardware. With only the built-in keyboard connected, I used device manager to uninstall the keyboard, then rebooted as prompted. Problem solved! (I've posted this long comment in the hope that it will get indexed and help others.)
    – Bob Brown
    Apr 22, 2020 at 20:59

I've just tried to resolve it for an hour, on the phone with a friend who had an opposite issue (only 5 6 and left control were NOT working). What eventually worked for him was:

Control+Alt+Fn (or Windows key instead of Fn)

Note that in some cases the left Control is not working so you should try with any of these. Of course try typing the non-functional keys each time to see if it worked.


Have you tried the keyboard on another system? Is this a usb keyboard or a PS/2 keyboard? Have you tried plugging it into different ports?

If you answered yes to all of these points then I would suggest 1 of 2 different actions. Try a system restore back a day or two before this happened and see if that fixes it.

If that does not fix it and this is a PS/2 keyboard try a USB one.


If you're using an USB to PS/2 adapter, that might be causing the issue... Defective ones are known to cause this error.


I could not resolve a big keyboard problem that suddenly appeared from nowhere - most keys did not work, and those that did were not acting as usual. I had tried plugging in a USB keyboard to see if the usual wireless one had gone AWOL, but the USB keyboard behaved identically. So I (wrongly) decided it had to be the PC+software at fault.

I noticed by a lucky accident that the Alt key on the wireless keyboard was stuck in the depressed condition. As I had never removed that keyboard from the equation it obviously affected the USB keyboard too. So check that none of your keys on any connected keyboards are jammed down!


I had the same issue with iBall wireless keyboard. Keys 5,6,F1,F2,+,-,=_ were not working. I opened the keyboard and cleaned it with a tissue paper. It had very small dust particles. After cleaning it worked perfectly.

*be careful when opening the keyboard as you may drop all the rubber contacts and will have to place them again.


This question now 9 years old, but the issue is still occurring. I have an HP Pavillion Sleekbook, 15-b010tx running Windows 8.1 Professional. The computer runs NordVPN (using NordLynx protocol) and Avira AntiVirus.

Up until a week ago, there were no issues; then we noticed that the numeric keys above the letters stopped working, with the exception of 5 and "=".

After experimentation, I found that pressing the "=" key and then "backspace" cleared the problem and restored keys to full functionality .... until it happens again a minute, an hour or a week later - completely random. I have not as yet managed to find any rhyme or reason as to why this occurs - although ... probably coincidence .... it started happening after the most recent 8.1 update ....


Try using a USB keyboard, this resolved my problem. I used to have a port microphone type one before and wasn't compatible with this Windows.

  • This question is 5 years old... A USB keyboard has already been suggested in another answer. The name for the "port microphone type" is PS/2.
    – MC10
    Aug 19, 2015 at 21:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .