0

I'm just trying to clone my dual boot system to do something like a "clone backup", but I can't boot my system on the another notebook after the complete restore. (Maybe is something with the grub and dev mapper, but I'm not absolutely sure)

That was what I'm done until right now:

1 - Used Clonezilla to complete clone and restore my dual boot system (Have LUKS and LVM);

2 - The option that I selected was "Clone Disk" and not only "partition clone";

3 - I'm trying to clone and complete restore a dual boot to another notebook (dell to toshiba);

4 - Maybe, I'm not absolutely sure about that, but I'm thinking if my problem is with the grub and dev mapper, because when I compare two notebooks that is the only difference. After the cloning with clonezilla, the grub and dev mapper wasn't cloned too.

Someone can help me analyse and solve this problem?

I've some attachments with fdisk, lvdisplay, vgdisplay and pvdisplay so we can analyze.

Thanks.

4
  • Since the PC's are not identical, they likely require different drivers. A Fiat fuel injector wouldn't be likely to fit a Ford. You could install CentOS on the Toshiba if it already has Windows 10, and copy data from the Dell to the Toshiba., but don't expect a simple clone to work. – DrMoishe Pippik Sep 1 '19 at 2:35
  • Yeah, friend. I've been thinking about that possibility too, but I'm not quite sure if the problem is caused by the hardware and drivers differences. Maybe I don't need the system work entirely on Toshiba, I just have to be ensured that my clone backup is working and restoring to Toshiba is the only possibility I can think until right now. – LakeParanoaSurfist Sep 1 '19 at 12:41
  • Any tool, such as clonezilla or dd for Linux, which must be run with the HDD unmounted, or Macrium reflect for Windows, which can be run while the Window OS disk is mounted (or from external media), should be able to make an image of the drive that can be easily restored... Just as safe as cloning, and some can be restored to a larger disk, as well as identical. – DrMoishe Pippik Sep 1 '19 at 18:17
  • Unfortunately, I already tried to create an img disk from my system by using a boot pendrive with Clonezilla, so I think my HDD was unmounted. Anyway, I'll give a chance for this Macrium software. Today I was testing another possibility to access my cloned disk by using the rescue tool from CentOS booted pendrive and the rescue tool detected my Linux system on "/dev/sda7" so I could access my device by executing the chroot /mnt/sysimage command, but it seems temporary cuz when I boot my system nothing changes. Now I need to know how to permanently configure to boot correctly. – LakeParanoaSurfist Sep 2 '19 at 1:19
0

Ok, I did not complete this task using clonezilla, but I've used veeam backup to backup my entire system (Dualboot+Luks), so it worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.