0

On MacOS I was not getting the shift+cmd+left/right/up/downto work.

Repro:

  1. Open VSCode
  2. Go to Code->preferences->keyboard shortcuts
  3. Click on keyboard symbol on far right.
  4. press shift+cmd+left/up/down/right.

Result: none of them are interpreted. All that is displayed is shift+cmd+

0

Fix:

Hunted around... Discovered that Mission Control was using all of these keys. So I remapped them all to other Function keys (that I do not use in editing).

There are 2 places to check:

  1. System preferences->Mission Control
  2. System preferences->Keyboard->Shortcuts->Mission Control

After remapping, it still did not work!

Close and restart Visual Studio Code and then it works!

Posted here so others do not have to struggle with this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.