0

I have a MacBook Pro (Touch Bar version) with a US keyboard layout. For some reason, I bought a Logitech Craft keyboard with a Japanese layout. The Logitech Craft keyboard can be successfully connected with the Mac without any problem. The Logitech Options software are also installed. Nothing was wrong with the Logitech keyboard software installation on my MacBook Pro. The keyboard is functioning normally.

I set the default keyboard layout for my Mac to US layout because the keyboard attached to the MacBook Pro is US. I add Japanese as the second language on Mac, so that I could type Japanese characters using the keyboard (for both MacBook Pro keyboard and the Logitech Craft keyboard). I can type Japanese characters (for Hiragana, Katakana, and Kanji conversion) using this settings on both keyboard.

What I want to do is, I want to type a normal English text (with the symbol characters as printed on top of the keys as well) using my Japanese layout external Logitech Craft keyboard. However, it seems that there is no way for me to change the layout settings on my Mac of the Logitech Craft external keyboard to Japanese layout. The QWERTY key mapping of the keyboard is not the problem. Japanese and US keyboard mapping for the QWERTY characters is the same but some of the symbol characters are not.

Is there any options to change the (external) keyboard layout on macOS X to Japanese layout where the default layout for MacBook's internal keyboard is US?

It seems that there are no options to change the layout for Romaji layout of Japanese language to Japanese keyboard layout in Keyboard Input Source settings for Japanese language (see screenshot). So I am currently stuck with US keyboard layout for my Japanese external Logitech keyboard.

Any help would be really appreciated, thank you.


Screenshot for Input Sources settings

0

i had same issue with logitech k780 external keyboard for my mbp2012 Mojave. i solved problem as following using a Japanese website. how to switch your mac keyboard from US layout to JP layout

1.update "logitec options" and "logitec unifying software" to newest update. (make sure right OS version is detected.)

2.go to: "system settings" => "keyboard" at the bottom left there should be a "change keyboard type" button. click it.

3.keyboard setup assistant should come up. follow instructions on detecting keyboard type.

4.if keyboard was detected by mac, a JIS/ANSI/ISO option list will show up. choose "JIS".

5.your keyboard should now be working in Japanese keyboard layout. no more qwerty!

hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.