0

I have 2 sata hard disk drives. I have installed windows 10 os on one and red hat enterprise Linux 7 on other and made both of them bootable. But always , when I boot, it directly goes into windows 10. The boot order in bios is configured to load windows installed hard drive first and then Linux installed hard drive next. I need to see dual boot on the post screen, so that I could select which one to log in.

Note: I have uefi bios and installed both operating system as legacy bios in uefi.

  • A few questions: First, why are you booting in legacy instead of uefi? Second, is there a reason you cannot dual boot with a small partition on the first hard drive and just format the second as ext4 for your Linux data? Additional reading: itsfoss.com/guide-install-linux-mint-16-dual-boot-windows – RudyB Sep 2 '19 at 13:18
  • @RudyB when I got my assembled PC , a year and a half ago, the seller had installed in that way. Now, I am trying to install Linux alongside windows and in recent , I understand this difference between bios and uefi. To answer your second question, I have 1 TB HDD where my windows is working and I got another 1 TB HDD recently for Linux. – Vijayanand A Sep 2 '19 at 18:41
  • @VijayanandA You need to know and understand the difference because they have different requirements and installation methods. You also need to understand partitions and partition tables. If you don't you may end up bricking your working OS. – user931000 Sep 2 '19 at 20:42
0

Seeing that you installed both in Legacy BIOS mode on a UEFI system, the problem would be the boot order.

Since you are attempting to load the Windows hard drive first, it cannot load GRUB (Linux bootloader), therefore rendering the dual-boot scenario unable to work.

It is much easier to install both OSes in UEFI mode if you have a UEFI computer, especially since Windows 8.1 and up is tuned to work with UEFI, and GRUB also has an EFI mode.

The solution to this problem, therefore, would be to reinstall both your OSes in UEFI mode and to start booting GRUB (grubx64.efi) first. Sometimes, at least in my experience on separate hard drives, you would not see the boot menu. If you start booting straight to RHEL 7 without seeing a boot menu as you desire, when you boot into RHEL, open up a Terminal and run these commands

sudo os-prober
sudo update-grub

Then you should be good to go. Reboot and you would see the GRUB menu.

  • Thanks Varun, you mentioned that I need to reinstall windows OS in uefi mode. Before I start, I wanted to confirm, if in legacy bios mode itself , is there a way to bring the grub boot loader in the logon menu for me to choose. (Considering, both windows OS and rhel OS is installed on 2 HDD as legacy BIOS with MBR partitioned) – Vijayanand A Sep 3 '19 at 6:52
  • It is recommended that you bring them up in UEFI mode because dual booting between them is easier that way. It is sometimes possible to skip that step and to just move the hard drive with RHEL to the top of the boot order, but in my experience, that doesn't usually work. – Varun Narravula Sep 3 '19 at 14:11
  • I already changed the boot order priority in uefi bios to load Linux installed HDD as first and I did rebooted but still it goes into windows. I have 2 queries here: #1: is my motherboard Asus rog strix b450 f support Linux grub boot loader? #2:. Is there any setting or configuration that I need to identify which says dual boot is supported between 2 hard disk in my motherboard? My processor and ryzen supports windows, rhel and ubuntu – Vijayanand A Sep 3 '19 at 16:56
  • Possibly GRUB got broken by the Windows installation. This sometimes happens with RHEL if you install Windows after RHEL. So boot into your install disk, and run "sudo grub-install /dev/sdX" where X is the hard drive where RHEL is installed. – Varun Narravula Sep 3 '19 at 17:01
  • I first installed windows 10 OS, a year back, which is still working good. Now I am installing Linux – Vijayanand A Sep 4 '19 at 0:11
0

Windows has taken over from GRUB, so it needs to be repaired.

Perhaps the best tool for the job is Super Grub2 Disk, which should work in almost any configuration.

Download the ISO and create a bootable media. You would find a tutorial in the article
Wizard – Restore Grub with Super Grub2 Disk.

0

I changed the csm mode in uefi bios and changed both of my hard disk to gpt partitioned table and disabled fast boot in bios. Now dual OS works fine.

Thanks all who responded to my problem and answered my question

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.