3

As stated in the title, I’ve got an ATA security-locked hard drive that I cannot seem to unlock. The locking happened after I started an ATA security-enhanced erase from Ubuntu’s Disks utility. The power went out in the middle of the process and upon the next boot, I could not do anything with the drive other than view its SMART status. I’ve chased a number of leads and tried some solutions that have worked for others in a similar predicament, but haven’t found any success. (I don’t know the exact nature of the problem, so I’m posting here rather than AskUbuntu.)

Output of SeaChest_Erase -d PD1 -i (the Seagate-supplied software for manipulating its hard drives): Output of SeaChest_Erase -d PD1 -i

Solutions that other people have tried:

From the way the others solved their lock-out problem, I assume I will have to get/do any of 5 things:

  • The master password for a Seagate ST12000VN0007 (or just my particular drive)
  • The user password set by the Ubuntu Disk utility during the secure erase
  • The user password I might have accidentally set while fiddling with Victoria or hdparm
  • A specific hardware adapter in combination with one of the above
  • Wait 24 hours with the drive being active to see if the erasure completes

But I find it unlikely that I set the password myself since all unlocking and password setting actions resulted in failure messages. Parted Magic uses “password” as the password. Synology uses “synology” as the lock password. Does Ubuntu’s Disks utility use some known default password in the background to lock the drive? Would the drive automatically resume erasing to completion if left alone?

1

Both these links were helpful to me in solving the issue:

https://forums.linuxmint.com/viewtopic.php?t=271260

https://askubuntu.com/questions/1120971/gnome-disks-utility-locked-hdd

This was the command I used:

sudo hdparm --security-disable xxxx /dev/sd?

Simply replace the question mark with the letter which designates your locked drive.

"lsblk" should tell you which one it is.

| improve this answer | |
  • This seems closest to solving the issue as the problem is pretty much the same. The output of the command, though, produces “Illegal Request: Unaligned write command” and “Data Protect: Access denied - no access rights” which is puzzling. Funny how the other guy found it in the source code. I was just heading there myself. I’ll try this in combination with the other solutions mentioned before and see where that gets me. – Kevin Li Sep 3 '19 at 0:43
  • Is there any chance I could have reset the password using any of the hdparm commands? – Kevin Li Sep 3 '19 at 2:03
  • You could try also booting up your PC without the HDD plugged in and "hot-plugging" it after it's reached the OS before you make your attempts to disable the lock. – coincidental_guest Sep 3 '19 at 23:51
  • Well, that seemed to work! $ sudo hdparm --security-disable 'xxxx' /dev/sdd security_password: "xxxx" /dev/sdd: Issuing SECURITY_DISABLE command, password="xxxx", user=user – Kevin Li Sep 7 '19 at 18:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.