0

We recently updated PHP to version 7.2. We had to reboot the server to apply the changes. The site originally ran on apache but was changed over to nginx about a year or two ago by another admin who has now left. After the reboot apache started automatically and the site ran of apache unknown for 2 days.

The OS is Cpanel 11.68 autoinstaller (CentOS 6 64bit) (64bits).

Today I made changes to the wordpress file and folders permissions as we noticed they were incorrect after rebooting the server. Then things started going wrong.

First off was this error in the wordpress error-log

WordPress database error Can't create/write to file '/tmp/#sql_221b_0.MAI' (Errcode: 28 "No space left on device")

Upon investigation I found that Inodes may have been the problem. When I run df -i I got the following output

Filesystem        Inodes   IUsed     IFree IUse% Mounted on
rootfs           3203072 3203072         0  100% /
/dev/root        3203072 3203072         0  100% /
devtmpfs         8241707    2422   8239285    1% /dev
/dev/md3       118865920  193826 118672094    1% /home
tmpfs            8250083       1   8250082    1% /dev/shm
/dev/root        3203072 3203072         0  100% /var/tmp

Based on this article I deleted the /var/tmp folder and rebooted the system but it still shows Iuse at 100% for the var/tmp folder.

When I run df -h I get the following

Filesystem      Size  Used Avail Use% Mounted on
rootfs           48G   24G   22G  53% /
/dev/root        48G   24G   22G  53% /
devtmpfs         32G  508K   32G   1% /dev
/dev/md3        1.8T  147G  1.6T   9% /home
tmpfs            32G     0   32G   0% /dev/shm
/dev/root        48G   24G   22G  53% /var/tmp

As the Inodes is reporting at 100% Use I'm making an assumption that this is where the problem lies and not in the permissions.

I've deleted logs from various directories and even deleted a 122gb backup file that was created on Sunday in /home/backup/weekly/YYYY-MM-DD/accounts/ but still the problem exists.

I've also had numerous errors in the WHM complaining about not being able to write to cache because of permissions at 600 and No space left on device

How can I tell if it's a problem with permissions or Inodes?

If it is a problem with Inodes how can I fix it? There is only 2 files at 4.0k in /var/tmp/ now, plus a symlink to mysql.sock

If it is a problem with permissions how can I find the correct permissions/directory to change?

1 Answer 1

0

What fixed my issue was just clearing the TMP directory and restarting the server. You can also try to just restart the mysql service. We are running CentOS as well so hopefully it's a similar issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.