0

As title I am using Apache Atlas 2.0 in CDH without hive hook and HA. When I drop hive table, apache atlas still show the table is active. My atlas-application.properties is

#########  Graph Database Configs  #########

atlas.graph.storage.backend=hbase2
atlas.graph.storage.hbase.table=atlas

atlas.graph.storage.hostname=ip
atlas.graph.storage.hbase.regions-per-server=1
atlas.graph.storage.lock.wait-time=10000 
atlas.EntityAuditRepository.impl=
org.apache.atlas.repository.audit.HBaseBasedAuditRepository

# Graph Search Index
atlas.graph.index.search.backend=elasticsearch
atlas.graph.index.search.hostname=ip
atlas.graph.index.search.elasticsearch.client-only=true
atlas.graph.index.search.max-result-set-size=150

atlas.search.defaultlimit=100

atlas.search.maxlimit=10000

#########  Notification Configs  #########
atlas.cluster.name=primary
atlas.kafka.zookeeper.connect=ip:2181,ip:2181,ip:2181
atlas.kafka.bootstrap.servers=ip:9092,ip:9092,ip:9092
atlas.kafka.zookeeper.session.timeout.ms=400
atlas.kafka.zookeeper.connection.timeout.ms=30000
atlas.kafka.zookeeper.sync.time.ms=20
atlas.kafka.auto.commit.interval.ms=1000
atlas.kafka.hook.group.id=atlas
atlas.kafka.enable.auto.commit=false
atlas.kafka.auto.offset.reset=earliest
atlas.kafka.session.timeout.ms=60000
atlas.kafka.offsets.topic.replication.factor=1
atlas.kafka.poll.timeout.ms=1000

atlas.notification.create.topics=true
atlas.notification.replicas=1
atlas.notification.topics=ATLAS_HOOK,ATLAS_ENTITIES
atlas.notification.log.failed.messages=true
atlas.notification.consumer.retry.interval=500
atlas.notification.hook.retry.interval=1000

#########  Security Properties  #########

# SSL config
atlas.enableTLS=false

atlas.authentication.method.kerberos=false
atlas.authentication.method.file=true

#### ldap.type= LDAP or AD
atlas.authentication.method.ldap.type=none

#### user credentials file
atlas.authentication.method.file.filename=
${sys:atlas.home}/conf/users-credentials.properties

### groups from UGI
#atlas.authentication.method.ldap.ugi-groups=true

#########  Server Properties  #########
atlas.client.readTimeoutMSecs=60000
atlas.client.connectTimeoutMSecs=60000
atlas.rest.address=http://localhost:21000

#########  Entity Audit Configs  #########
atlas.audit.hbase.tablename=apache_atlas_entity_audit
atlas.audit.zookeeper.session.timeout.ms=1000
atlas.audit.hbase.zookeeper.quorum=ip:2181,ip:2181,ip:2181

#########  High Availability Configuration ########
atlas.server.ha.enabled=false

######### Atlas Authorization #########
atlas.authorizer.impl=simple
atlas.authorizer.simple.authz.policy.file=atlas-simple-authz-policy.json

#########  CSRF Configs  #########
atlas.rest-csrf.enabled=true
atlas.rest-csrf.browser-useragents-regex=^Mozilla.*,^Opera.*,^Chrome.*
atlas.rest-csrf.methods-to-ignore=GET,OPTIONS,HEAD,TRACE
atlas.rest-csrf.custom-header=X-XSRF-HEADER

############ Atlas Metric/Stats configs ################
atlas.metric.query.cache.ttlInSecs=900

#########  Gremlin Search Configuration  #########
#Set to false to disable gremlin search.
atlas.search.gremlin.enable=false

Is there anything wrong? Who can help me???

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.