0

I'm having trouble uploading PHP or CSS files via SFTP or making changes to a file via SSH to our Ubuntu server running Apache.

When upload the initial few files the server updates correctly and is reflected in the website via a browser(In my case it is Chrome). After multiple rounds of updates the website stops reflecting any changes to files.

This is the crux of my problem. No matter what method I use(WinSCP, CyberDuck or even nano in SSH), once the website stops updating not matter how much I modify a file it stops showing in the website. I don't understand why this happens if someone could explain it to me I'm sure the internet by and large would be very appreciative as there is next to nothing when it comes to this issue online, apart from timestamps and accidentally modifying a different file. I've double checked all of that and even got a 3rd party(a mate) to test and was able to replicate the same issue.

I used to use filezilla and this issue only popped up a few times. Now that Filezilla is no longer safe to use I've resorted to WinSCP and CyberDuck, however the problem is now so prominent that I cannot change anything on the server now.

I realise this question might be a silly blunder on my part, so any advice is most appreciated, I will try any suggestions placed here.

  • There's not some sort of caching turned on is there (eg mod_cache.so)? Also, have you tried a graceful (or otherwise) restart after updating the files? – Smock Sep 5 at 14:48
  • I've gone through all of the cache settings in winscp and switched them off furthermore, I clear the cache with every refresh after an upload in the browser. I've tried restarting the apache and ubuntu both from the AWS console and from SSHing directly onto the server and doing it there too. No luck. I'm unsure what "Graceful" is I will look it up now, thank you. – vmang Sep 5 at 14:58
  • Graceful Restart but if a normal restart doesn't sort it, a graceful won't either. Anyway, I'm asking about the cache settings in the apache config, not winscp config. – Smock Sep 5 at 15:02
  • Hey @Smock, I tried the grafeful restart too and it had no effect. I installed htcacheclean but I'm unsure as to how to use it, from the small bits that I managed to do, it seemed to me that it the cache in apache was already off but I'm not too sure. I don't know if this will help but when I do upload something to the server I can see the changes when I SSH on but the website doesn't show the changes in browser. – vmang Sep 6 at 10:26
  • If you're not using cache in apache it's possibly not the server. In your SSH session what happens if you do a curl/wget - are the changes reflected? If that looks ok, do you have any caching for web browsing set on your firewalls/network? (Are you in a company? Is the server internally hosted or externally? There may be some way to exclude that URL from the caching) – Smock Sep 6 at 10:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.