0

Unable to perform ssh to remote host over WSL:

OpenSSH_7.6p1 Ubuntu-4ubuntu0.3, OpenSSL 1.0.2n  7 Dec 2017
debug1: Reading configuration data /home/xxx/.ssh/config
debug1: Reading configuration data /home/xx/.ssh/hosts
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to 155.155.155.155 [155.155.155.155] port 22.
debug1: connect to address 155.155.155.155 port 22: Resource temporarily unavailable
ssh: connect to host 155.155.155.155 port 22: Resource temporarily unavailable

I`m using windows 10 default firewall and added outbound rule for port 22. Telnet returns same response as well:

Trying 155.155.155.155 ...
telnet: Unable to connect to remote host: Resource temporarily unavailable

In the same time I am able to connect via virtual machine to same remote host.

Could you please help?

Thank you

  • Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Are you sure there is an SSH service running on the server in question on the port you are using? – Ramhound Sep 5 at 15:24
  • Hello, yes there ii such service. I`m able to connect to the same host in the same time via virtual machine. – VLD62 Sep 5 at 20:48
  • This virtual machine is running an identical version of Windows and WSL I presume? Have you eliminated a possible OpenSSL compatability issue? – Ramhound Sep 5 at 21:03
  • Try to allow the ssh in Windows Firewall. – Biswapriyo Sep 5 at 21:13
  • I have added a inbound and outbound rules on port 22 in Windows firewall. I am also able to connect from the wsl via ssh to the virtual machine. Also ssh from powershell to the remote host is working fine. Tried to add wsl.exe to the firewall exceptions, not working still, tried to completely disable the firewall, again not working. – VLD62 Sep 7 at 3:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.