0

I got both the Apache and Nginx servers working fine until I ran:

sudo certbot --nginx -d myhost.com -d www.myhost.com

and restarted Nginx.

I got the error

nginx: [crit] pread() "/etc/nginx/sites-enabled/mod_rpaf-stable" failed (21: Is a directory)

Is it a permissions issue , or a problem with mod_rpaf-stable? I tried to find information online but I'm getting nowhere.

1

It sounds like you've erroneously placed mod_rpaf-stable to /etc/nginx/sites-enabled/. The latter expects NGINX configuration files with .conf extension, named after domain names of websites you intend to host on your server.

The mod_rpaf belongs to the Apache world, and it has nothing to do with NGINX. Remove it or move out outside NGINX configuration directory.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.