0

I am using Vmware workstation 15 on a laptop which is connected to Wifi network.

I am having Debian and Ubuntu instances running as virtual machines.

The host OS (Windows 10) is having following IP

Connection-specific DNS Suffix  . : xyz.cyd.com    
Link-local IPv6 Address . . . . . : de80::706b:4222:6799:f404%23 
 IPv4 Address. . . . . . . . . . . : 10.1.1.31  
 Subnet Mask . . . . . . . . . . . : 255.255.224.0 
 Default Gateway . . . . . . . . . : 10.1.0.1

Now my vmware network settings are as in box below

vmware network serttings2.png

Now on my virual machines the IP I am getting are in the range

Debian Virtual machine shows

debian@debian:~$ ip a

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
    valid_lft forever preferred_lft forever 2: ens33: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000

    link/ether 00:0c:29:6c:78:50 brd ff:ff:ff:ff:ff:ff
    inet 192.168.20.132/24 brd 192.168.20.255 scope global dynamic   
    noprefixroute ens33
    valid_lft 1304sec preferred_lft 1304sec
    inet6 fe80::20c:29ff:fe6c:7850/64 scope link noprefixroute
    valid_lft forever preferred_lft forever

and Ubuntu Virtual machine shows

osboxes@osboxes:~$ ip a

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group  
    default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
    valid_lft forever preferred_lft forever

2: ens33: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 00:0c:29:a9:92:d6 brd ff:ff:ff:ff:ff:ff
    inet 192.168.20.130/24 brd 192.168.20.255 scope global dynamic 
    noprefixroute ens33
    valid_lft 1368sec preferred_lft 1368sec
    inet6 fe80::ac1e:acaf:d2fb:b59/64 scope link noprefixroute 
    valid_lft forever preferred_lft forever

The situation is like this

                                                                                                                       |

 Wifi Router  (10.1.0.1)   
            Windows 10--(vmware)-----|IP (10.1.1.31)    
              |
              |
              |------Debian Guest OS (virtual machine) IP 192.168.20.132/24
              |-----Ubuntu Guest  OS (virtual machine)192.168.20.130/24

Other machines which are connected on network

are having IP ranges in 10.1.0.1 to 10.1.0.255 I want to be able to do an SSH from Debian Guest OS or Ubuntu Guest

OS to machines in my network. So what should be my network settings at vmware workstation to be able to do so. enter image description here

Where as I want the guest OS is to get IP address in range of host OS ,i.e. the Virtual machines get the IP from Wifi router of network.

There are multiple virtual machines I am having how do I achieve in all these virtual machines. Because I need to ssh into

other machine and if IP are not in same ranges I can not do an SSH from virtual machines to other machines on network.

I want IP of virtual machines to be in ranges 10.1.1.X which is also the IP address of host OS windows 10.

How do I achieve this?

  • 1
    The default setting for VMware Workstation is NAT. That is why you are getting a 192.168.x.y address in the machine. In VMware Workstation, go the VM (do not start it), Edit Virtual Network Settings. In the dialog window that opens, change the Network Adapter setting to "Bridged" . Now start the machine and set it up and it should get an IP address on your wireless network router. – John Sep 8 at 10:43
  • 1
  • Thanks both of your comments have helped me to solve my problem. – political science Sep 9 at 4:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.