2

It seems that Windows 10 Pro v1903 suspends Microsoft Outlook (365 or 2019 with latest office build v1908) when remote desktop user disconnects session (user closes session and does not log off).

In summary, we use remote desktop to connect to a clean install Windows 10 v1903 VM with Microsoft Outlook installed (365 or 2019 with latest build 1908). We set Outlook to Offline mode, queue 10 emails, turn Outlook back to online and quickly disconnect the session (not logging user out). I would expect that the emails should be sent. This however does not happen and is only sent when I log back into the remote session.

We can confirm that:

  1. It is not a Windows 10 power and sleep setting, as all screen savers, sleep modes and such are disabled.
  2. It is not a ‘System unattended sleep timeout’ as set out in this post. Bear in mind that the ‘suspension’ is immediate and does not take effect after 1 or 2 minutes.
  3. It is not the NIC that is suspended, as we ran console ping tests while disconnected, which continued to poll.
  4. But most importantly, an exact duplicate of the setup, using a Windows 10 Pro v1809 build, does not suspend Outlook build 1908, and the queued emails is successfully sent.
  5. Updated. Changed group policy settings' Session Time Limits as suggested by harrymc, but it was unsuccessful.
  6. Updated. The Terminal Server registry fix suggested here by harrymc , did not resolve the problem.
  7. Workaround This disconnect shortcut proposed by harrymc DID WORK as interim workaround.

We are therefore convinced the problem is with a setting change on remote desktop users in Windows v1903. We have found that only Outlook is so far affected.

Any comment that might point us in the right direction to restore the functionality to Outlook whilst the remote session is disconnected, will be highly appreciated.

2 Answers 2

0

The Microsoft article Configure Timeout and Reconnection Settings for Remote Desktop Services Sessions says:

By default, Remote Desktop Services allows users to disconnect from a remote session without logging off and ending the session. When a session is in a disconnected state, running programs are kept active even though the user is no longer actively connected.

So it seems that someone changed the default on that computer.

You should check that appropriate Group Policy settings are set to Not configured or are configured as Enabled with the value of Never:

  • Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits

  • User Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits

4
  • Thank you for your suggestion. On the v1809 build these setting have not been configured, although Outlook still runs after Remote User disconnects. On the v1903 build, I have configured the settings to Never, but Outlook is still suspended when remote user disconnects. Bear in mind that other applications on the VM are not suspended, ie the command line ping test continued to function. As soon as I log into the v1903 build, emails are sent. I updated the question with these tests.
    – Daniel
    Sep 9, 2019 at 6:40
  • See also this answer. If nothing works, this might be a bug with v1903 which can be reported using the Feedback Hub, and in the meantime use this workaround, with more info here.
    – harrymc
    Sep 9, 2019 at 8:04
  • Thank you harrymc. The registry fix did not resolve the problem. However your workaround is working. Thank you very much. I have updated the question for completeness.
    – Daniel
    Sep 9, 2019 at 9:32
  • keep in mind that when using the work-around with tscon that the session stays open without lock! that means that anyone that has a connection to the console (for example via virtual machine manager console or vsphere) can use the open session even from another user without logging in. So in the used script there should also be a session lcok Oct 4, 2019 at 12:41
0

Thought this deserved a separate answer: Microsoft has released the KB4522355 cumulative update for Windows 10 1903.

Some issues of note they mention being fixed:

  • Addresses an issue with high CPU usage in Desktop Window Manager (dwm.exe) when you disconnect from a Remote Desktop Protocol (RDP) session.
  • Addresses an issue that allows the system to go to Sleep (S3) after two minutes of inactivity even if you configure the sleep timer to never sleep.
  • Addresses an issue that causes the system to stop responding at the sign-in screen.
  • Various VPN fixes.

The first one listed above is an issue I saw on many other threads when people were discussing oddities with RDP, 1903, and sometimes Outlook.

Have you had a chance to install this update to see if it fixes your issue? Your situation is by far the most reproducible I have seen. If it still isn't fixed, maybe a support call with Microsoft? Start a GoFundMe page to pay for it and I'll donate. Our issue (which still persists) is too intermittent to even start a call with MS.

EDIT: Our issue is resolved, so the update to 1903 appears to have done the trick. I hope it works for you as well!

2
  • 1
    Your other answer was deleted as a (overly long) comment asking for clarification is not an answer. This is not a forum and answers should be just that: answers. If you are requesting clarification then you should post a comment using the "add comment" button below the question.
    – Mokubai
    Oct 26, 2019 at 16:44
  • Thank you for the clarification and guidance, Mokubai.
    – sutekh137
    Oct 29, 2019 at 13:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.