13

Whenever I put my Windows 10 device into battery saver mode, I get the following message:

Skype notification

Update your Background Apps setting

You may be missing Skype calls and messages due to your current settings.

If I go to the Windows Settings app, I only see an option to disable all notifications from Skype, which I don't want because I do in fact use Skype. The Skype app itself doesn't provide a setting to disable just this notification. (I'm using the Windows Store app.)

Can I disable this annoying toast notification without disabling any other Skype notifications or functionality?

  • You can disable Skype from running in the background in Settings > Privacy > Background apps. – harrymc Jan 22 at 9:43
  • @harrymc: Please reread the question. I don't want to disable Skype itself or any functionality other than that notification. – bwDraco Jan 22 at 16:48
7
+50

The reason you receive this message is because Windows automatically prevents Skype from running as a background process in Battery saving mode.

To prevent this message and conserve all functionalities, follow these steps:

1) Go into Settings. Then select System. Afterwards, select Battery

2) On the top, under the battery life estimate, you will see a choice named Battery usage by app. Select this.

3) This will give you a list of apps and their impact on the battery. Find Skype in this list.

4) Select Skype and uncheck the choice written "Let windows decide when this app can run in background" (I use a french OS, so the exact text may differ.)

5) Then underneath, select the choice written "Authorize this app to run in background."

Skype will now be able to run without limitations even on battery saving mode. The message discussed above will no longer be displayed when switching to power saving mode.

*Note that this applies only from Windows 10 version 1607 and higher. I highly suggest updating windows if you have an earlier version.

Edit: You cannot disable a single notification in Windows 10. It is either all the notifications are enabled or disabled for a single app or service.

| improve this answer | |
  • 1
    Okay, but is there a way to suppress this notification only, without changing anything about whether Skype is allowed to run in the background? – bwDraco Jan 23 at 3:10
  • There is no way of disabling a single notification in windows 10. You can only disable an app completely from notifying you. There is no inconvenience of letting Skype always run in the background, besides a very small increase in power draw. – Natsu Kage Jan 23 at 16:27
  • This is good enough for me, so I'll award the bounty. – G-Wiz Jan 23 at 22:27
  • I'm a bit reluctant to do so, but I guess this is the only proper fix so I'll accept it. – bwDraco Jan 24 at 18:48
0

I think it's important to explicity say that this notification is coming from the Skype app, and not from Windows per se. As @Natsu stated, when your computer enters power-saving mode, Windows prevents (at least some of) Skype's functionality from running - the intention being, to conserve the battery power that Skype would otherwise use. The Skype dev team has obviously decided to counteract this a little, and so Skype detects when this happens and notifies the user to let them know that they could potentially be missing calls/messages.

So, that leaves you with a few options... You can:

  1. Accept the situation, and essentially ignore this Skype notification, which can't be turned off within Skype individually
  2. Disable all Skype notifications entirely - Windows allows you to enable/disable notifications on a per-app basis
  3. Uninstall Skype
  4. Prevent your computer from ever going into power-saving mode
  5. Allow Skype to run fully in power-saving mode

The last option is probably the one you want. See @Natsu's answer for how to do that. Theoretically, your battery will be depleted faster because Skype is using additional power, but you're probably headed for a power outlet at this point anyway, so you probably won't mind if it runs fully in power-saving mode.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.