1

I have installed VMware workstation 12 player in my windows 10 Home 64 bit. My processor is AMD.

Whenever I try to run the virtual machine it shows error saying I have to disable credential guard.

The Error I am getting

However, Credential guard was already turned off .

Credential guard was already turned off

I did not find Device Guard option in Local Group Policy to disable it.

Device Guard option missing

Please help me run Virtual Machine in my windows 10 Home 64 bit.

2

According to the KB article your error message referenced, it only affects VMware Workstation versions 12.5 and older. An upgrade to the latest (v15.1) should do the trick.

|improve this answer|||||
2

This answer doesn’t apply to Windows 10 version 1903+

Whenever I try to run the virtual machine it shows an error saying I have to disable credential guard.

You should indeed upgrade to a newer version of VMWare Workstation, however, I am aware this comes at a cost. The good news is there is a solution to your problem. I should add that VMWare Workstation 12 is fully supported on Windows 10, any incompatibility with newer versions of Windows 10, would only be an issue if you were trying to run them within your VM which isn't the case.

However, Credential Guard was already turned off.

Core Isolation is not considered Credential Guard. Your screenshot only indicates Core Isolation is disabled.

I did not find Device Guard option in Local Group Policy to disable it.

This is due to the fact you are using Windows 10 Home. The policy in question only on supported versions of Windows 10. The simplest solution to your problem is to use the Windows Defender Device Guard and Windows Defender Credential Guard hardware readiness tool, and then run the following command in an elevated command prompt.

DG_Readiness_Tool_v3.6.ps1 -Disable -AutoReboot

In addition to running the command, you should very the following registry keys do not exist. If you delete these keys you must perform a reboot.

HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\DeviceGuard\EnableVirtualizationBasedSecurity

HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\DeviceGuard\RequirePlatformSecurityFeatures 

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\LSA\LsaCfgFlags

HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\DeviceGuard\LsaCfgFlags

Source: Manage Windows Defender Credential Guard

|improve this answer|||||
0

Thank you so much for your help. The following method worked for me.

  1. Open Registry Editor.
  2. Go to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\DeviceGuard.
  3. Add a new DWORD value named EnableVirtualizationBasedSecurity. Set the value of this registry setting to 0 to disable it.

  4. Go to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\LSA.

  5. Add a new DWORD value named LsaCfgFlags. Set the value of this registry setting to 0 to disable it.
  6. Open CMD with administrative privilege.

  7. Enter this code

    bcdedit /set hypervisorlaunchtype off

That's it. Done!

However, If you need hypervisor again you can later re-enable from CMD by entering

bcdedit /set hypervisorlaunchtype auto
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.