0

I have an Office 365 subscription, and I am having problems signing into the desktop software.

  • When I click the "Sign In" button, I am prompted for my username.
  • I enter my company email address, and click "Next".
  • Normally, at this point, I would expect to see a password prompt, but the dialog just disappears. Essentially, it's as if I had hit the close button.

Here are some other observations:

  • I first noticed this after I had moved my SSD from one laptop to another.
  • If I go to the Account options in the Office application, it tells me the product is activated. Clicking "Manage Account" takes me to office.com, where I am signed in with my company Microsoft account.
  • I have tried uninstalling and reinstalling the Office 365 applications multiple times.

Affected products:

  • I have zero issues with any of the web based Office 365 apps, or logging into any Microsoft site.
  • All desktop Office 365 applications seem to be affected.
  • OneNote 2016 is affected.
  • The "OneNote for Windows 10" application is NOT affected.
  • The OneDrive desktop application is NOT affected.

My thoughts:

  • This could be related to swapping the SSD to a new laptop
  • I have not tried re-building my local Windows profile (this is a huge pain due to all the software I have configured)... but I can if need be...

Thanks in advance for any assistance you can provide!


Edit: More information. I re-built my Windows profile, and I am now getting an error stating "Your computer's Trusted Platform Module has malfunctioned. If this error persists, contact your system administrator with the error code 80090034.". I updated the BIOS, with no effect. (I did not see specific drivers for TPM)

  • You should ask your IT folks about this. – music2myear Sep 11 '19 at 3:53
  • "I first noticed this after I had moved my SSD from one laptop to another" Is the new laptop identical to the old one (i.e. same model)? If not, was the drive sysprepped first? – Mr Ethernet Sep 11 '19 at 10:55
  • @music2myear - I did. They closed my ticket without resolving it. Figured I'd ask while my boss handled that issue. I ended up fixing it this morning tho (I'll post an answer) – Michael Christiansen Sep 12 '19 at 14:17
  • @wrecclesham - Yes, same model. I ended up fixing it tho (I'll post an answer) – Michael Christiansen Sep 12 '19 at 14:17
  • I'm glad you fixed it and sorry your IT folks didn't reach out with a resolution. However, we will not support "shadow IT" here. The rules and standards of your workplace are something we cannot speak to, and these will have significant involvement in the correct solution to any problem. This is why we always point people dealing with issues with their work computers back to their company support staff. – music2myear Sep 12 '19 at 20:52
1

I figured out the solution, and it makes sense. This Microsoft article titled "DPAPI MasterKey backup failures when RWDC isn't available" indicates that when a domain user logs in for the first time, and can't contact a read/write domain controller, then DPAPI keys can't be backed up. I'm guessing Office365 uses DPAPI to store your credentials.

I am a remote user. When I deleted/recreated my user account, I was NOT connected to the corporate VPN, so Windows may not have been able to backup my DPAPI keys to the domain controllers.

Not sure where the TPM errors came into play, as (as far as I know) DPAPI doesn't use TPM... but it could have been a generic cryptographic error.


Solution was to set this registry key:

HKEY_LOCAL_MACHINE\Software\Microsoft\Cryptography\Protect\Providers\df9d8cd0-1501-11d1-8c7a-00c04fc297eb\ProtectionPolicy = 1 (DWORD)

0

Try this method:

Go to the registry editor (Win+R; regedit)

go to HKEY_CURRENT_USER -> Software -> Microsoft ->Office -> 16.0 ->Common -> Identity

Inside "Identity", create a new REG_DWORD value called "EnableADAL" and leave the value at 0

Restart the PC and try again to login from Office 365. In my case, the logon screen was now different and it worked perfectly.

Please note: you should back up the registry once you modify it. Review How to back up and restore the registry in Windows

  • I ended up finding the cause (I created an answer for it). I didn't get a chance to try your answer out... But, thanks for your suggestion! – Michael Christiansen Sep 12 '19 at 14:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.