I use a Windows 10 machine remotely at work. Both the local and remote machine are in the same ISP network (not same local network, but same ISP). I've been using it like that for almost a year now and I had never experienced absolutely any issues.

Until recently. I don't know if anything specific triggered this behavior, but I feel that it started happening after I upgraded the remote to W10 1903. I later upgraded the local one as well and I feel that it only made the problem worse (but I don't really have any data).

From time to time, the session will freeze - the image stops updating. However, what I type and mouse clicks are still being sent. No error message is shown whatsoever, the image simply freezes. To make it work again, I have to close and re-open the session. Everything that I had typed and/or clicked while it was frozen is there.

Is there any way I can debug this?

8 Answers 8


I also ran into this issue since July 2019 on a Windows 10 1903 acting as the client machine. The following workaround on the client works for me, so that RDP no longer freezes.

Start an elevated command prompt (run cmd.exe as administrator), and then run:

reg add "HKLM\software\policies\microsoft\windows nt\Terminal Services\Client" /v fClientDisableUDP /d 1 /t REG_DWORD

After that, close and reopen all your RDP sessions on your client computer to restart the Remote Desktop Client (mstsc.exe, aka Microsoft Terminal Services Client) application.

I'm waiting for a final fix to this issue.

Follow-up: I am not sure, but it looks like fixed in 21H1 (both client and server must run 21H1 or higher). For me I no longer see freezes without the disable UDP workaround.

  • 4
    Thank you! Been using RDP for over a decade and never had issues until 1903. I am keeping my fingers crossed that this is my solution! Sep 27, 2019 at 13:10
  • 2
    Thanks! Haven't had a freeze for over a day now, what a relief. I was restarting RDP about 20 times a work day, absolutely horrible experience. I assume following the instructions in this post lets you turn off the UDP protocol by policy setting.
    – adabyron
    Oct 2, 2019 at 22:38
  • 9
    This is still broken in Windows 10 1909. (I updated my server from Windows 7 and this problem started at that point). The UDP workaround prevents the freezing, but ultimately UDP is preferable for this protocol.
    – derek1284
    Jan 14, 2020 at 14:21
  • 14
    How can RDP be broken and this not be a major issue given how central RDP is to Windows?
    – Mr. Boy
    Apr 8, 2020 at 12:17
  • 3
    @Mr.Boy The MS developers don't handle packets being lost, or received out of order, when UDP is enabled. Next up: a hash list that crashes if there's a collision.
    – Ian Boyd
    Jun 23, 2020 at 12:58

Encountered this with Windows 10 (1903 and 1909).

Manifestations of the problem:

  1. RDP session updates oddly, distorting audio and video.

  2. RDP session hard-freezes. Client window is responsive, but the content within it is essentially a static image.

    • Sometimes the RDP session recovers, resuming normal function.

    • Other times the RDP session seems to hang indefinitely. No error messages seen; client window can be closed and restarted normally.

Speculated causation:

  • Seems to occur primarily when using the UDP protocol under load.

  • My guess is that the RDP protocol has lost some of its resilience to packets getting lost or out-of-order.


No single work-around seems complete. For example, I've had RDP completely freeze even in TCP-only mode. However, TCP-only coupled with trying to improve network connectivity or/and reducing load (such as video and audio) seems to greatly reduce the incident rate.

  1. Partial work-around: Improve network connectivity.
    A direct local connection may be relatively reliable.

  2. Partial work-around: Reduce network strain.
    Reducing RDP session settings, avoiding audio, and avoiding video seem to help.

  3. Full-ish work-around: Disable UDP.
    RDP seems to behave a lot better with TCP than UDP. Switching to TCP-only does seem a bit more laggy, but the lag is more ordered (which is strangely nicer than the erratic lag) and I've yet to encounter an indefinite hang.

    Three ways to implement (probably mutually compatible, but probably only need to do one):

    1. On client: Local Group Policy Editor
      → Local Computer Policy
      → Computer Configuration
      → Administrative Templates
      → Windows Components
      → Remote Desktop Services
      → Remote Desktop Connection Client
      → Turn Off UDP On Client
             → Enabled

    2. On server [untested]: Local Group Policy Editor
      → Local Computer Policy
      → Computer Configuration
      → Administrative Templates
      → Windows Components
      → Remote Desktop Services
      → Remote Desktop Session Host
      → Connections
      → Select RDP transport protocols
             → Enabled
             → Use only TCP

    3. Not recommended (tweaking Registry Editor)
      Source: @robbiefan's answer.
      On client: Registry Editor
      → Computer
      → SOFTWARE
      → Policies
      → Microsoft
      → Windows NT
      → Terminal Services
      → Client
      → [right-click] → New → DWORD (32-bit) Value
             → Name: fClientDisableUDP
             → Value data: 1
             → Base: Decimal
      Note: This seems to have worked for me when I tried it, but can't verify much beyond that. I reverted this solution after trying it, preferring to rely on the Group Policy instead.

Discussion: Background

I'm fuzzy on the details, but in short, I think there was something about some bugs being discovered in the RDP protocol as implemented prior to Windows 10 1903:

  1. CVE-2019-1181 | Remote Desktop Services Remote Code Execution Vulnerability;

  2. CVE-2019-1182 | Remote Desktop Services Remote Code Execution Vulnerability.

Then Windows 10 1903 was meant to fix these, I think.

Apparently the new version of the RDP protocol has some issues, e.g. this one. Disabling UDP (to force TCP) seems to be a decent enough work-around, though the protocol can feel a bit laggier. That said, the older RDP protocol also had some rather obnoxious audio latency problems that seem to be a lot better now, so, personally, I'm happy about that!

  • Ugh, just had my first freeze under TCP-only, so I guess it's still just a partial work-around. A pretty good partial, though.
    – Nat
    Mar 14, 2020 at 22:10
  • 1
    not for me with that update. However I'm using RDP over SSTP VPN - I think VPN within this can also cause some issues. Mar 25, 2020 at 19:43
  • 1
    I did this manually on my local and remote PC's. Usually anytime I would compile my apps the output log of the compile would cause the session to freeze almost immediately. This solved my problem by disabling UDP.
    – chdev77
    Apr 17, 2020 at 2:42
  • 3
    And in case you're running Win10 Home, a helpful link to get gpedit.msc enabled (because it's not there by default): itechtics.com/enable-gpedit-windows-10-home
    – NateJ
    Jun 18, 2020 at 23:44
  • 2
    this issue is still severe (April 2021), the TCP switch does improve. But introduces lag and blurring. And a desynch of sound & video in media playback. But more stable and predictable. I tested solution 2. with apparently appreciable results.
    – v.oddou
    Apr 26, 2021 at 8:34

For me, connecting with Remote Desktop over VPN, the fix seems to be to disable Persistent bitmap caching under Show Options >> Local Experience

options dialog

Windows 10 Home build 18363 connecting to Win10 Enterprise build 18363 over Checkpoint VPN.

I tried disabling UDP as per the top voted answer but that resulted in frequent outright disconnects instead of frozen-screen symptoms.

Update: This isn't a complete fix. The freezing happens less often but still happens. I can trigger the freezing semi-"reliably" by copying dozens to hundreds of rows in Excel. Appears to be sensitive to size of the selection (smaller is less likely to freeze). Disabling clipboard under Local Resources doesn't seem to matter.

  • Will give this a try ... If it works will come back and give this a vote up ..
    – Allan F
    Aug 25, 2020 at 4:57
  • 1
    nope .. still a freeze an hour or so after trying this ..
    – Allan F
    Aug 25, 2020 at 6:47
  • 1
    @AllanF post updated. For me it seems to be related to Excel and copying. Aug 26, 2020 at 21:12
  • Same .. something to do with copy to clipboard ..
    – Allan F
    Aug 28, 2020 at 1:53
  • 1
    I wonder if disabling animations might help? The hypothesis being that RDP's buffer is getting overloaded with micro-updates, which might be reduced if micro-animations are disabled.
    – Nat
    Dec 22, 2020 at 22:50

I have had this issue for several weeks. I believed it to coincide with my laptop (that I'm connecting too) coming under heavy load.

This made me think that its possibly a result of the laptop throttling itself and loosing packets/connection, possibly as a result of prioritizing other things..

Yesterday I placed my laptop on 3 upside down shot glasses and aimed a fan at it to keep it cool.

I have not had a disconnect since. So from getting this issue at least 10 times per day I now have 0 cases in 2 days.

Not a real fix, but possibly something to keep in mind as a temporary workaround.


The UDP rule looks like it works but the performance will decrease a lot, I decided to continue researching for more cases, and I found this being related with mine.

SOLVED: Found that when the default option of passing through "Smart cards" was checked, the RDP session would freeze shortly after being established. When that was unchecked from RDP's Local Resources tab, problem went away. Why would Smart cards (which we don't use at my place of employment) cause such an issue? I am not sure how Smart Card would in any way impact an RDP session, but as part of moving to Windows 10, we have also started using Microsoft Group Policy recommended baseline settings, which MAY well include some sort of setting, or lack of setting that might have a bearing on this. Either way, sharing in case others encounter this issue.

  • 3
    Note: I started encountering this problem despite already having the check-box for smart cards unchecked, so this may not be a full solution.
    – Nat
    Mar 13, 2020 at 23:05
  • 2
    Same as @Nat, I have Smart Cards disabled, yet this issue can still occur, so your solution doesn't solve the issue completely. Apr 2, 2020 at 8:23

I ran across an issue with the same symptoms and tried all the UDP gymnastics on this thread to no avail. I set them all back to defaults. Turns out Windows 10 RDP has an issue when one of the host's monitors is vertically oriented while the client does not have a vertical monitor. If the vertical monitor is disabled, RDP works like a champ. v1903


I turned off all local resources I didn't strictly need, such as audio input and output, and video input (webcam), and mine is working better, still on UDP.


Encountering a similar issue, I resolved it by switching to the Microsoft Store version of Remote Desktop.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .