0

bit of an odd one i was hoping someone might be able to help me out with. I need to update the host file on a clients MAC in order to resolve a particular url to an internal ip address. I've been able to do this easily enough on half a dozen other on site MAC books but i've got stuck on their newest macbook (running mojave 10.14.5). When i try opening the host file with nano sudo (which worked a-ok on all the other machines) i just get this:

empty hosts file

usually i'd see the host file entries all listed so i can edit it as needed and then commit the changes.

Since i wasn't having much luck with sudo nano i tried copying the hosts file from it's folder location to the desktop but this failed with a "One or more items in 'hosts' can't be changed because they are in use' error message. The file shows as ghosted out in Finder and has a padlock in the bottom right when I view the Info of the file.

Can anyone suggest how i might go about updating the hosts file? The sudo nano method has always worked for me before so i'm a bit stumped by this. Any help/advice would be greatly appreciated.

Cheers

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.