0

The following page is LDAP Authenticated. When a user attempts to access this page, they are prompted for LDAP credentials. I'm using Apache 2.2

Main Folder Browser Page

Attempting to access a subfolder results in permission denied despite being authenticated via LDAP

Authentication Failure Page

The page is configured via a .conf directive in conf.enabled

<AuthnProviderAlias ldap auth>
  AuthLDAPURL ldaps://XXXXXXX:636/ou=XXXXXXX,o=XXXXXXX,c=XXXXXXX?uid
  AuthLDAPBindDN "XXXXXXX=XXXXXXX,ou=XXXXXXX,ou=XXXXXXX,o=XXXXXXX,c=XXXXXXX"
  AuthLDAPBindPassword "XXXXXXX"
</AuthnProviderAlias>

<VirtualHost *:81>
  Alias /jenkins "/files/"
</VirtualHost>

<Directory /files/>
  Options Indexes FollowSymLinks
  AllowOverride None
  AuthType Basic
  AuthName "XXXXXXX CDSID"
  AuthBasicProvider auth
  Require ldap-group CN=XXXXXXX
  Require valid-user
</Directory>

<VirtualHost *:81>
  <Location /jenkins>
    ProxyPreserveHost On
  </Location>
</VirtualHost>

The following worked fine for Apache 2.2

<VirtualHost *:80>
        Alias /jenkins "/proj/jenkins/builds/"
</VirtualHost>

<Directory /proj/jenkins/builds/>
        Options Indexes FollowSymLinks
        AllowOverride None
        Require all granted
</Directory>

<Location /jenkins>
        AuthName "XXXXXXX"
        AuthType Basic
        AuthBasicProvider ldap
        AuthLDAPUrl XXXXXXX
        AuthLDAPBindDN __LDAP_USERNAME__
        AuthLDAPBindPassword __LDAP_PASSWORD__
        <RequireAll>
                <RequireAny>
                        Require valid-user
                </RequireAny>
                <RequireAny>
                        Require ldap-group XXXXXXX
                </RequireAny>
                <RequireNone>
                        Require user "ANONYMOUS LOGON"
                </RequireNone>
        </RequireAll>
</Location>

Sorry for all the blanking, my company has a pretty strict confidentiality policy.

New contributor
cdahmedeh is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

cdahmedeh is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.