0

I have trouble using rsync to backup my local home folder to a remote server (chh2). When I type the following command:

  rsync -v -e ssh /home/* chh2@192.168.1.67:~/Documents/chh1_backup

I get the following error:

  Warning: No xauth data; using fake authentication data for X11    
  forwarding.
  skipping directory chh1
  sent 16 bytes  received 12 bytes  18.67 bytes/sec
  total size is 0  speedup is 0.00

I have no trouble establishing a connection with ssh -X chh2@192.168.1.67 nor do I have any trouble with scp.

I have tried all combinations of the following lines in /etc/ssh/config:

 #   ForwardAgent no 
     ForwardX11 yes
 #   ForwardX11Trusted yes

and none of them made any difference. Does anyone know how to put me on the right path with this? Much appreciated!

1

You're seeing skipping directory chh1 because rsync does not recurse into directories by default. Add the -r option to recurse, or even better, -a (equivalent to -rlptgoD), which preserves a bunch of metadata to put into the copy.

Explanation of rsync -rlptgoD:

https://explainshell.com/explain?cmd=rsync+-rlptgoD

  • Thanks Deltik. Spot on! That solved the problem. – Christian Hick Sep 12 at 0:41
  • @ChristianHick: Glad to see your problem is solved! You can indicate this by checking the gray check mark to the left of this answer. – Deltik Sep 12 at 1:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.