0

I have an M2 500GB hard drive that I have been using as the boot drive for my windows 10 PC. One day the PC crashed and since then whenever I boot the PC it boots to a blue screen. So I decided to format the HD and reinstall windows 10. I used an M2 to USB connector and tried to format the drive but nothing works. I can read and see the files on the hard drive but I'm unable to format nor delete any of the files. I've tried gparted on linux, disk utility on mac and also tried to format the drive with windows, nothing helps. Is the hard drive faulty or somehow protected against formating?

  • 1
    What happens exactly when you attempt to format the drive? You indicated you are unable to format the driver, but do not actually indicate, the reason you are unable to do so. – Ramhound Sep 12 at 4:18
  • When I tried to format it with Windows it either hangs and makes the computer very slow or the process idles. On Linux, it throws errors that this partition can't be formated. – Manolis Sep 12 at 7:04
  • Have you tried to format it in the original slot? It can be a problem with the USB adapter. – GabrielaGarcia Sep 12 at 17:43
  • @GabrielaGarcia Tried that, but it didn't work – Manolis Sep 13 at 1:54
0

The drive is damaged and the internal firmware is deeming the error to be non-recoverable. That is why it is locking it into a read-only mode to prevent the data from being destroyed. This is a common mechanism with flash storage of all kind, including M.2 and USB flash drives. The only thing you can do at this point is to get the data you need and buy a new one.

  • 1
    Another possible explanation is the problem is due to the USB adapter being used. – Ramhound Sep 12 at 5:44
  • I don't think there is an issue with the USB adapter. When the m2 is installed inside the pc, the windows 10 installation media can't write on the drive. – Manolis Sep 12 at 8:03
  • @TuxStash.de is there a way to check if there is an issue with the drive? – Manolis Sep 12 at 8:12
  • @Manolis Look for a tool on the manufacturers website to check the drive. If you tell me the brand, I can search it for you. – TuxStash.de Sep 12 at 16:57
  • 1
    @TuxStash.de found it on their site adata.com/en/ss/software-6 thanks for the recommendation. – Manolis Sep 13 at 1:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.